Bug 818486 - SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'read' accesses on the file /home/lamp/k (deleted).
SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'read' ac...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:29fd8acb3f0bb06489b484d7226...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 04:39 EDT by Riccardo Angelino
Modified: 2012-06-27 23:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 23:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Riccardo Angelino 2012-05-03 04:39:15 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.2-6.fc16.x86_64
reason:         SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'read' accesses on the file /home/lamp/k (deleted).
time:           gio 03 mag 2012 10:38:59 CEST

description:
:SELinux is preventing /opt/google/chrome/nacl_helper_bootstrap from 'read' accesses on the file /home/lamp/k (deleted).
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that nacl_helper_bootstrap should be allowed read access on the k (deleted) file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep nacl_helper_boo /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0
:                              -s0:c0.c1023
:Target Context                system_u:object_r:user_home_t:s0
:Target Objects                /home/lamp/k (deleted) [ file ]
:Source                        nacl_helper_boo
:Source Path                   /opt/google/chrome/nacl_helper_bootstrap
:Port                          <Sconosciuto>
:Host                          (removed)
:Source RPM Packages           google-chrome-stable-18.0.1025.168-134367.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-84.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.2-6.fc16.x86_64 #1 SMP
:                              Sat Apr 21 12:43:20 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    gio 03 mag 2012 10:38:25 CEST
:Last Seen                     gio 03 mag 2012 10:38:25 CEST
:Local ID                      6d63d668-ed51-427b-8b4d-aaeab43d9937
:
:Raw Audit Messages
:type=AVC msg=audit(1336034305.972:75): avc:  denied  { read } for  pid=3294 comm="nacl_helper_boo" path=2F686F6D652F6C616D702F6B202864656C6574656429 dev="sda5" ino=1966088 scontext=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1336034305.972:75): arch=x86_64 syscall=execve success=yes exit=0 a0=7f9f03d16298 a1=7f9f03d10210 a2=7fffe27168c0 a3=7fffe2713550 items=0 ppid=2 pid=3294 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=nacl_helper_boo exe=/opt/google/chrome/nacl_helper_bootstrap subj=unconfined_u:unconfined_r:chrome_sandbox_nacl_t:s0-s0:c0.c1023 key=(null)
:
:Hash: nacl_helper_boo,chrome_sandbox_nacl_t,user_home_t,file,read
:
:audit2allow
:
:#============= chrome_sandbox_nacl_t ==============
:allow chrome_sandbox_nacl_t user_home_t:file read;
:
:audit2allow -R
:
:#============= chrome_sandbox_nacl_t ==============
:allow chrome_sandbox_nacl_t user_home_t:file read;
:
Comment 1 Daniel Walsh 2012-05-03 10:05:57 EDT
This looks like a leaked file descriptor.  Any idea what /home/lamp/k
was?
Comment 2 Daniel Walsh 2012-05-03 10:07:39 EDT
Added dontaudit.

Fixed in selinux-policy-3.10.0-121.fc17
Comment 3 Fedora Update System 2012-06-15 06:30:50 EDT
selinux-policy-3.10.0-89.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-89.fc16
Comment 4 Fedora Update System 2012-06-15 19:52:18 EDT
Package selinux-policy-3.10.0-89.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-89.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9507/selinux-policy-3.10.0-89.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-27 23:26:44 EDT
selinux-policy-3.10.0-89.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.