Bug 818488 - voms-api-java requires old jakarta-commons-* packages
Summary: voms-api-java requires old jakarta-commons-* packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: voms-api-java
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-03 08:39 UTC by Stanislav Ochotnicky
Modified: 2013-02-27 18:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-14 16:37:51 UTC


Attachments (Terms of Use)

Description Stanislav Ochotnicky 2012-05-03 08:39:26 UTC
Package voms-api-java and/or subpackages either requires or buildrequires following jakarta-commons packages:
jakarta-commons-cli
jakarta-commons-lang

These packages have been deprecated and apache-commons variants should be used in their place. Please update your package.

Comment 1 Mattias Ellert 2012-05-04 17:47:17 UTC
Why?

The choice to Require and BuildRequire jakarta-* rather than apache-* was deliberate. The apache-* packages Provides the jakarta-* names, but the jakarta-* packages don't Provide the apache-* names. Requiring jakarta-* will always work. Requiring apache-* will fail on old distributions like EPEL 5 and EPEL 6, so insisting on using the apache-* Requires for newer distributions would result in introducing more conditionals in the spec file to use different Requires for different distributions. I currently see no need to do this, since the more simple solution to use the same Requires everywhere works fine. 

Unless you know of any plans to drop the jakarta-* Provides from the apache-* packages?

Comment 2 Mattias Ellert 2012-06-14 16:37:51 UTC
No reply from reporter - closing.

Comment 3 Stanislav Ochotnicky 2012-06-15 13:25:38 UTC
Hmm, seems like I missed this from my mail queue and then...oh well. Anyway, the jakarta provides in apache commons were supposed to be temporary for the duration of few fedora releases (which they were). I'd like to eventually get rid of them. 

On one hand I prefer to keep specs for EPEL/Fedora separate since they tend to diverge anyway. But that's not my call for your packages.

However keeping those provides for another 7 or so years...i.e. 14 fedora releases, seems...excessive. I don't like it, because it means it will creep into another RHEL release and the cycle will never end. We will have to keep that old provides indefinitely.

Comment 4 Fedora Update System 2013-02-12 05:56:12 UTC
voms-api-java-2.0.10-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/voms-api-java-2.0.10-2.fc16

Comment 5 Fedora Update System 2013-02-12 05:56:34 UTC
voms-api-java-2.0.10-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/voms-api-java-2.0.10-2.el6

Comment 6 Fedora Update System 2013-02-12 05:56:55 UTC
voms-api-java-2.0.10-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/voms-api-java-2.0.10-2.fc18

Comment 7 Fedora Update System 2013-02-12 05:57:14 UTC
voms-api-java-2.0.10-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/voms-api-java-2.0.10-2.el5

Comment 8 Fedora Update System 2013-02-12 05:57:32 UTC
voms-api-java-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/voms-api-java-2.0.10-2.fc17

Comment 9 Fedora Update System 2013-02-21 05:32:27 UTC
voms-api-java-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-02-21 05:50:42 UTC
voms-api-java-2.0.10-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-02-27 18:00:51 UTC
voms-api-java-2.0.10-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-02-27 18:04:50 UTC
voms-api-java-2.0.10-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.