Bug 818511 - ltrace -l option does nothing
ltrace -l option does nothing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ltrace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 04:56 EDT by Richard W.M. Jones
Modified: 2015-05-04 21:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:15:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-05-03 04:56:20 EDT
Description of problem:

According to the man page, it's supposed to limit the
output to just the symbols from the named library.  However
on Fedora 17 it doesn't seem to do anything at all.

For example:

$ ltrace -l /lib64/libselinux.so.1 ls -lZ 
(0, 0, 2, 3, 128)                                = 0x3e8a221280
__libc_start_main(0x402a40, 2, 0x7fff7bf0a588, 0x4122f0, 0x412380 <unfinished ...>
strrchr("ls", '/')                               = NULL
setlocale(6, "")                                 = "en_GB.UTF-8"
bindtextdomain("coreutils", "/usr/share/locale") = "/usr/share/locale"
textdomain("coreutils")                          = "coreutils"
__cxa_atexit(0x40ab90, 0, 0, 0x736c6974756572, 3) = 0
isatty(1)                                        = 1
getenv("QUOTING_STYLE")                          = NULL
getenv("COLUMNS")                                = NULL
ioctl(1, 21523, 0x7fff7bf0a130)                  = 0

Note that glibc calls are still being shown.

I also tried other programs and other libraries, but the -l
option did not appear to have any effect.

Version-Release number of selected component (if applicable):

ltrace-0.6.0-4.fc17.x86_64

How reproducible:

100%

Steps to Reproduce:
1. ltrace -l <some_library> <program>

Actual results:

-l option doesn't affect the output.

Expected results:

-l option should limit the output to the selected libraries.

Additional info:
Comment 1 Petr Machata 2012-05-03 09:24:09 EDT
Hmm, so people actually do use -l.  I should implement this on the upstream libs branch and in F18, that's not supported at all right now.

It should work on F17 though, I'm not aware of any changes that would break this.  I'll look into it.
Comment 2 Petr Machata 2012-05-03 15:13:49 EDT
This is silly.  ltrace simply overwrote the internal counter of loaded libraries
with 0 on start-up.
Comment 3 Fedora Update System 2012-05-03 15:16:12 EDT
ltrace-0.6.0-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ltrace-0.6.0-11.fc17
Comment 4 Richard W.M. Jones 2012-05-03 17:09:46 EDT
I tested this on a couple of libraries and it now
seems to be doing the right thing.  Thanks for the
quick response.
Comment 5 Fedora Update System 2012-05-03 23:09:31 EDT
Package ltrace-0.6.0-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ltrace-0.6.0-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7253/ltrace-0.6.0-11.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-26 03:15:48 EDT
ltrace-0.6.0-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.