Bug 818573 - curl command for looking at templates incorrect
curl command for looking at templates incorrect
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity low
: beta6
: ---
Assigned To: Dan Macpherson
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 08:14 EDT by james labocki
Modified: 2012-12-10 16:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:53:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-05-03 08:14:06 EDT
Section 5.5 of the Cloud Engine User Guide

# curl https://[RHEVM-HOST]:8443/api/templates --user [USER]@[DOMAIN]:[PASSWORD]

should read

# curl -k https://[RHEVM-HOST]:8443/api/templates --user [USER]@[DOMAIN]:[PASSWORD]

without the -k option (for insecure) curl will output the following

# curl https://rhevm2.rhev.local:8443/api/templates --user admin@internal:redacted
curl: (60) Peer certificate cannot be authenticated with known CA certificates
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
 of Certificate Authority (CA) public keys (CA certs). If the default
 bundle file isn't adequate, you can specify an alternate file
 using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
 the bundle, the certificate verification probably failed due to a
 problem with the certificate (it might be expired, or the name might
 not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
 the -k (or --insecure) option.
Comment 2 Dan Macpherson 2012-08-28 22:59:51 EDT
Added -k switch.

My only minor reservation with this bug is that it's using an insecure method to communicate with the RHEVM server. Although I doubt there'd be any chance of a man in the middle attack when communicating between Cloud Engine and a private cloud, I still feel a little uncomfortable documenting the use of -k switch. I don't want customers to get the impression that this is standard practice.
Comment 13 Lana Brindley 2012-11-18 21:45:30 EST
This documentation has now been dropped to translation ahead of publication. For any further issues, please open a new a bug.

LKB
Comment 14 Lana Brindley 2012-12-10 16:53:24 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.