Red Hat Bugzilla – Bug 818594
libgpod.pc Requires: libimobiledevice-1.0 ... overlinking
Last modified: 2012-08-10 15:14:59 EDT
libgpod2's %_libdir/pkgconfig/libgpod.pc file currently contains
Requires: glib-2.0 >= 2.8.0 gobject-2.0 gdk-pixbuf-2.0 libimobiledevice-1.0
which results in all those needlessly getting linked into all pkg-config-using
target apps (even when not linking statically). I noticed this while helping do a libimobiledevice mass-rebuild awhile back.
I'd suggest patching this to be
Requires.private: glib-2.0 >= 2.8.0 gobject-2.0 gdk-pixbuf-2.0 libimobiledevice-1.0
instead (perhaps for rawhide only, reducing this linking may expose
underlinking bugs in target apps)
Created attachment 581862 [details]
pkgconfig patch to avoid overlinking
patch applied, poke me if anything breaks.