Bug 818635 - subscription-manager uninstallable on 6.1
subscription-manager uninstallable on 6.1
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Jay Greguske
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 11:31 EDT by James Laska
Modified: 2013-09-02 03:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 09:13:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-05-03 11:31:15 EDT
Description of problem:

Due to a known issue in the RHEL subscription-manager package, CloudForms is providing a newer version of the subscription-manager package (subscription-manager-0.96.17.2-3.el6_2).  This package is made available in the cf-tools repos ...

> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/i386/cf-tools/1.0/os
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/x86_64/cf-tools/1.0/os
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.2/i386/cf-tools/1.0/os
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.2/x86_64/cf-tools/1.0/os
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6Server/i386/cf-tools/1.0/os
> http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6Server/x86_64/cf-tools/1.0/os

Unfortunately, the subscription-manager package fails to install on RHEL6.1 due to an unmet rpm dependency.  I'm unclear why this problem has surfaced now.  Perhaps this is due to the recent CDN refresh on stage.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install and configure katello
2. Import a valid manifest and sync content from cdn.rcm-qa.redhat.com
3. Create a system template with the following repos included:
 * Red Hat Enterprise Linux 6 Server RPMs x86_64 6.1 - http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/x86_64/os
 * Red Hat CloudForms Tools for RHEL 6 RPMs x86_64 6.1 - http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6.1/x86_64/cf-tools/1.0/os
4. Add the 'subscription-manager' package to the system template
5. On a CloudEngine system, attempt to build the system template from steps #3-4
  
Actual results:

Image build fails due to the following dependency:

> SubprocessException: 'ssh -i /etc/oz/id_rsa-icicle-gen -F /dev/null -o ServerAliveInterval=30 -o StrictHostKeyChecking=no -o ConnectTimeout=10 -o UserKnownHostsFile=/dev/null -o PasswordAuthentication=no root@192.168.122.190 yum -y install "subscription-manager" "katello-agent" "aeolus-audrey-agent" "rhev-agent" ' failed(1): Warning: Permanently added '192.168.122.190' (RSA) to the list of known hosts.
> Error: Package: subscription-manager-0.96.17.2-3.el6_2.x86_64 (Red_Hat_CloudForms_Tools_for_RHEL_6_RPMs_x86_64_6.1)
>            Requires: python-rhsm >= 0.96.11
>            Installed: python-rhsm-0.95.14-1.el6_1.noarch (@anaconda-InstallationRepo-201105101844.x86_64/6.1)
>                python-rhsm = 0.95.14-1.el6_1
>            Available: python-rhsm-0.95.6-1.el6.noarch (Red_Hat_Enterprise_Linux_6_Server_RPMs_x86_64_6.1)
>                python-rhsm = 0.95.6-1.el6

Image build also fails when trying to build an i386 image:
> root@192.168.122.244 yum -y install "subscription-manager" "katello-agent" "aeolus-audrey-agent" "rhev-agent" ' failed(1): Warning: Permanently added '192.168.122.244' (RSA) to the list of known hosts.
> Error: Package: subscription-manager-0.96.17.2-3.el6_2.i686 (Red_Hat_CloudForms_Tools_for_RHEL_6_RPMs_i386_6.1)
>            Requires: python-rhsm >= 0.96.11
>            Installed: python-rhsm-0.95.14-1.el6_1.noarch (@anaconda-InstallationRepo-201105101829.i386/6.1)
>                python-rhsm = 0.95.14-1.el6_1
>            Available: python-rhsm-0.95.6-1.el6.noarch (Red_Hat_Enterprise_Linux_6_Server_RPMs_i386_6.1)
>                python-rhsm = 0.95.6-1.el6

Expected results:

 * Either ...
   1) Don't ship a newer subscription-manager for 6.1 cf-tools/
   2) Don't provide cf-tools/ for 6.1 at all
   3) Include the python-rhsm from 6.2 in the 6.1 cf-tools repo
   4) <something better>

Additional info:
Comment 1 James Laska 2012-05-03 11:34:06 EDT
Setting the priority to urgent as I believe the presence of this failure impacts our support statement for building RHEL-6.1 images.
Comment 2 James Laska 2012-05-03 11:34:23 EDT
Re-assigning to release-engineering.
Comment 3 Chandrasekar Kannan 2012-05-03 11:40:41 EDT
my vote is for option 1) because rhsm qe currently does not validate placing
newer subscription manager packages on older operating systems...
Comment 4 Hugh Brock 2012-05-09 09:13:04 EDT
Not shipping newer subscription manager in cf-tools for 6.1, end of story.
Comment 5 James Laska 2012-05-09 09:39:13 EDT
(In reply to comment #4)
> Not shipping newer subscription manager in cf-tools for 6.1, end of story.

Hey, they pay me to be Mr. Pedantic ... 

To clarify, we already were shipping a newer subscription-manager for 6.1.  However, we weren't also shipping a newer python-rhsm that it required.

In any case, no objections here :)
Comment 6 Mike McCune 2013-08-16 14:14:21 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.