Bug 818647 - Errors when running "rhc domain status"
Errors when running "rhc domain status"
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 11:56 EDT by Nam Duong
Modified: 2015-05-14 21:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 12:49:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-05-03 11:56:05 EDT
Description of problem:
A user reported through an email to openshift@redhat.com that they are running into this error:
rhc domain status -l bjoern_weinbrenner@yahoo.de
Password:
Analyzing system
EFEnter passphrase:
FF..F
=================================================
||  Your system did not pass all of the tests  ||
=================================================
1) You need to be able to connect to the server in order to test authentication.
2) You must have an account on the server in order to test SSH key matches.
3) You must have an account on the server in order to test SSH key matches.
4) You must have an account on the server in order to test SSH key matches.

=========================================================
||  Something went wrong, and not all tests completed  ||
=========================================================
1) test_connectivity(Test1_Connectivity):
    NoMethodError: undefined method `body' for nil:NilClass
        /Users/bjoerne/.rvm/gems/ruby-1.8.7-p358/gems/rhc-0.91.12/bin/rhc-chk:171:in `fetch_url_json'
        /Users/bjoerne/.rvm/gems/ruby-1.8.7-p358/gems/rhc-0.91.12/bin/rhc-chk:231:in `test_connectivity'


NOTES:  This is not affecting their ability to use OpenShift nor ssh/git other than the fact that he can't run "rhc domain status".  I've only seen one instance of this so far.  This particular user was having ssh issues at first, but it ended up being his router that was causing him issues when trying to ssh onto his applications' gears.
Comment 1 Clayton Coleman 2012-05-03 17:47:26 EDT
Moving this to low severity for now, medium priority.
Comment 2 Clayton Coleman 2012-06-18 15:16:41 EDT
Still no recreation.
Comment 3 Clayton Coleman 2012-06-22 12:07:36 EDT
This is low priority because we are going to move rhc-chk into rhc setup with a user story eventually.
Comment 4 John (J5) Palmieri 2012-10-09 12:49:13 EDT
rhc domain show does not call rhc-chk anymore

Note You need to log in before you can comment on or make changes to this bug.