Bug 818656 - Boot from iscsi root hangs after installation
Boot from iscsi root hangs after installation
Status: CLOSED DUPLICATE of bug 815827
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 12:26 EDT by Vivek Goyal
Modified: 2012-05-08 13:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 13:51:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot hang serial console logs (52.67 KB, text/plain)
2012-05-03 12:45 EDT, Vivek Goyal
no flags Details

  None (edit)
Description Vivek Goyal 2012-05-03 12:26:57 EDT
Description of problem:

I am trying to install F17 in following configuration.

- Its a kvm virtual machine
- /boot partition is on a virtio-blk disk (/dev/vda)
- root (/) is on iscsi target (/dev/sda)

Anaconda completes the installation but after that booting the virtual
machine fails.

Dracut has mounted the root disk and I see quite a few services have started. But the moment "iscsid" is started, I see an error message "connection error"
and then system hangs. 

After a while some more error messages pop up as journal thread is writing
to iscsi disk.

So basically we seem to have dropped the iscsi connection for root disk. I am wondering why that's the case. Is it an iscsid issue or some kind of configuration co-ordination is required between dracut and iscsid for
iscsi root.

As I am not sure I am starting with dracut and CCing mike christie. Change the
component as deemed fit.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vivek Goyal 2012-05-03 12:45:22 EDT
Created attachment 581902 [details]
Boot hang serial console logs

Serial console logs
Comment 2 Mike Christie 2012-05-04 02:01:55 EDT
Pretty sure this is the same as:
https://bugzilla.redhat.com/show_bug.cgi?id=815827

which I was thinking was this in rhel 6.3:
https://bugzilla.redhat.com/show_bug.cgi?id=815355
Comment 3 Mike Christie 2012-05-08 13:40:45 EDT
I think this is a dup of
https://bugzilla.redhat.com/show_bug.cgi?id=815827
and it is now fixed.

Would it be ok to close this?
Comment 4 Vivek Goyal 2012-05-08 13:51:03 EDT
Sure. I am closing at duplicate of above. I will test it in my setup to make sure it works. If there are issues, I will reopen it.

*** This bug has been marked as a duplicate of bug 815827 ***

Note You need to log in before you can comment on or make changes to this bug.