Bug 818676 - [abrt] cups-1.5.2-8.1.fc16: __GI_raise: Process /usr/sbin/cupsd was killed by signal 6 (SIGABRT)
Summary: [abrt] cups-1.5.2-8.1.fc16: __GI_raise: Process /usr/sbin/cupsd was killed by...
Keywords:
Status: CLOSED DUPLICATE of bug 739743
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2825f06782a420e68144e4b74f6...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-03 17:40 UTC by scd
Modified: 2012-05-08 11:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-08 11:48:03 UTC
Type: ---


Attachments (Terms of Use)
File: dso_list (4.05 KB, text/plain)
2012-05-03 17:40 UTC, scd
no flags Details
File: maps (18.65 KB, text/plain)
2012-05-03 17:40 UTC, scd
no flags Details
File: backtrace (27.76 KB, text/plain)
2012-05-03 17:41 UTC, scd
no flags Details
File: backtrace (24.42 KB, text/plain)
2012-05-03 23:46 UTC, scd
no flags Details
File: backtrace (21.89 KB, text/plain)
2012-05-04 09:23 UTC, scd
no flags Details

Description scd 2012-05-03 17:40:52 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/sbin/cupsd -f
crash_function: __GI_raise
executable:     /usr/sbin/cupsd
kernel:         3.3.4-1.fc16.x86_64
pid:            1632
pwd:            /
reason:         Process /usr/sbin/cupsd was killed by signal 6 (SIGABRT)
time:           Do 03 Mai 2012 19:25:11 CEST
uid:            0
username:       root

backtrace:      Text file, 28430 bytes
dso_list:       Text file, 4152 bytes
maps:           Text file, 19101 bytes

build_ids:
:61aea344c391d8ca2c072b40c36b74bc28711038
:28579c89bda7f08dace218884d7a5561f3f5f89d
:5a491e02e37595592ec20c9c8c17442a46d8ddc6
:fc8df5efad8976eba0eebe467ef8736055391e68
:36f57a1f3d3f4436f63d1aac473a777597dce5dc
:12fdc5a85e732c3f5e8b57d5d2901f36654c88ff
:89017ab0b75e533e4294f74ee8f7db3daceea536
:fdff2d98463ddd6e8c3883936e12070b2d039e58
:bbb7c497ff14faf6e1a51da91e884427f670517f
:bce8fb6913e0b658c53b896b05d075af7fa5cf73
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:20636bd24ca415499a99e709f8ff392bd962f414
:368c3cee84c23ec196abdf632219adea6bc31f4f
:4ea09f2cc6fa21696beac3f95cdd4160cfddd35f
:8c83a4501e8ece047ee61ff201952696e6cef2a1
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:c6739204320eb15bdcdba039a2b183298170403e
:dacf32a9a2f2b5077ba944e7b835cca6f637f78f
:bebe4eeed376b182ab6f0b8a28200684d72f1922
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:eff059eba5bf53059362deacda700d01aa3673e5
:e2e67b3ae2579e1667b73ad385f61552931024e9
:888e650848c123e0c145e1bbf100f639bd8b308e
:9f7adc772aa8ef07ea68315b0b516749b72fe255
:f1eb6e4e907e1e42f557c5b8dc851c407c6f4ac4
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:2639b5594fe4d7897db63ecd1ebb9681438317a8
:b9d3a4213a482d034bebc7dc1ed2901a734a894d
:4b4a5ba403acccab2f72ebe3908b23a81cc239a2
:be507c791e34415e8f42f0e6030c889b2895cf9a
:66b8a549e5dfccb29eee911c9a1f987d05f12613
:0fccce2fdb46650674ef5b64fae5f25f14c88e08
:14063d4a97bae5e96c07a1a7c0e6ca5c982839f3
:e2d68a0ee0872365dcc8c6640b7cd7b94c8276f2
:381b7069d555ff62cc543b6f7d3053b9fdcf2c20
:8c49577fba3c97a9de9331b5245737f6250e831c
:ced174aa0f6fc21a03a8891d8b372c68e705c159
:e814ef8432b7dec42a0b8ec12b9abd9fc7f57b40
:05defc2b14da883e218300cf52703f6ab31b04a5
:7e38d4068ce4d86cb3f22c2676cbe7f8bdccc15d
:9db4e5fd24f3ebecbfd28027c817d1bd55be5277
:c8e7f118041a9f77e0dd673da11b5653be27b5a2
:36fc045d11fc55f1b455247938e651666e2c127e
:ab091b23d7cdd46464c444e3d43722150dac9885
:1a212c7f1515542b310ba92f6109efc9b5bf2b6e
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:17f981cb9dbb88e65022c2d49ef5f939da321833

comment:
:Tried to add Epson Stylus Color 670 via Gnome GUI (clicked "Add New Printer" , selected Epson printer,
:after it had been detected, clicked "Add")

environ:
:BOOT_IMAGE=/vmlinuz-3.3.4-1.fc16.x86_64
:PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
:SYSFONT=latarcyrheb-sun16
:LANG=en_US.UTF-8
:PWD=/
:KEYTABLE=us
:LISTEN_PID=1632
:LISTEN_FDS=3

smolt_data:
:
:
:General
:=================================
:UUID: 1233cfdd-1f9f-43e5-9b5b-da2458e71b9b
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 2793.74
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i5-2537M CPU @ 1.40GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 1401
:System Memory: 3868
:System Swap: 6141
:Vendor: SAMSUNG ELECTRONICS CO., LTD.
:System: 90X3A 0.1
:Form factor: Laptop
:Kernel: 3.3.4-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4147:404:5197:49304) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:278:5197:49304) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:5197:49304) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:5197:49304) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7241:5197:49304) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(5348:17239:5199:29057) pci, bcma-pci-bridge, NETWORK, BCM43225 802.11b/g/n
:(32902:7192:5197:49304) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:5197:49304) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7202:5197:49304) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33128:5197:49304) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:7171:5197:49304) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:5197:49304) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5197:49304) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:5197:49304) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:5197:49304) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-0b60a639-d3f5-4be2-949d-f2fa67fe040b / btrfs 4096 4096 24641024 14646472 13678144 0 0 0
:/dev/sda3 /boot ext4 1024 1024 129267 46526 39973 32768 32535 32535
:/dev/sda4 WITHHELD vfat 2048 2048 32695 32695 32695 0 0 0
:

var_log_messages:
:May  3 10:52:31 smindbad cupsd[1581]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 10:52:31 smindbad abrt[16216]: Saved core dump of pid 1581 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-10:52:31-1581 (1957888 bytes)
:May  3 10:56:11 smindbad cupsd[16349]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 10:56:11 smindbad abrt[16464]: Saved core dump of pid 16349 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-10:56:11-16349 (2023424 bytes)
:May  3 11:18:36 smindbad cupsd[1190]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 11:18:36 smindbad abrt[2871]: Saved core dump of pid 1190 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-11:18:36-1190 (3272704 bytes)
:May  3 11:18:46 smindbad cupsd[2898]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 11:18:46 smindbad abrt[2905]: Not dumping repeating crash in '/usr/sbin/cupsd'
:May  3 11:23:44 smindbad cupsd[2943]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 11:23:44 smindbad abrt[3272]: Saved core dump of pid 2943 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-11:23:44-2943 (4247552 bytes)
:May  3 11:23:44 smindbad cupsd[3277]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 11:23:44 smindbad abrt[3305]: Not dumping repeating crash in '/usr/sbin/cupsd'
:May  3 11:41:25 smindbad cupsd[3854]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 11:41:25 smindbad abrt[3922]: Saved core dump of pid 3854 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-11:41:25-3854 (1847296 bytes)
:May  3 19:25:11 smindbad cupsd[1632]: cupsd: ../sysdeps/posix/getaddrinfo.c:1662: rfc3484_sort: Assertion `src->results[i].native == -1 || src->results[i].native == a2_native' failed.
:May  3 19:25:11 smindbad abrt[3172]: Saved core dump of pid 1632 (/usr/sbin/cupsd) to /var/spool/abrt/ccpp-2012-05-03-19:25:11-1632 (1974272 bytes)

Comment 1 scd 2012-05-03 17:40:55 UTC
Created attachment 581912 [details]
File: dso_list

Comment 2 scd 2012-05-03 17:40:58 UTC
Created attachment 581913 [details]
File: maps

Comment 3 scd 2012-05-03 17:41:00 UTC
Created attachment 581914 [details]
File: backtrace

Comment 4 scd 2012-05-03 23:46:49 UTC
Next try to reproduce #818354 w/ debugging info, this time by adding printer via command line:

# lpadmin -p 'Epson%20Stylus%20Color%20670' -E -v usb://EPSON/Stylus%20COLOR%20670 -m /escp2-670/expert 
lpadmin: Success


backtrace_rating: 4
Package: cups-1.5.2-8.1.fc16
OS Release: Fedora release 16 (Verne)

Comment 5 scd 2012-05-03 23:46:53 UTC
Created attachment 581989 [details]
File: backtrace

Comment 6 scd 2012-05-04 09:23:41 UTC
cups.service crashes on startup

backtrace_rating: 4
Package: cups-1.5.2-8.1.fc16
OS Release: Fedora release 16 (Verne)

Comment 7 scd 2012-05-04 09:23:46 UTC
Created attachment 582065 [details]
File: backtrace

Comment 8 Tim Waugh 2012-05-08 11:48:03 UTC
Looks like a duplicate of bug #739743.

*** This bug has been marked as a duplicate of bug 739743 ***


Note You need to log in before you can comment on or make changes to this bug.