Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 818686

Summary: cli --user and --password after command name ends in confusing error
Product: Red Hat Satellite Reporter: Justin Sherrill <jsherril>
Component: HammerAssignee: Justin Sherrill <jsherril>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 6.0.0CC: lzap
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-05-15 08:47:32 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Justin Sherrill 2012-05-03 18:19:25 UTC
Description of problem:

Using the cli, but specifying the user/pass in the wrong place can lead to a confusing error:

$ katello system list --user=admin --password=admin
error: Missing credentials and unable to authenticate using Kerberos (more in the log file)


When i get this I am confused because i have provided credentials yet it is complaining i have not.  we need a better error message.

Correct syntax with better error about a different arg that is missing:

$katello --user=admin --password=admin system list 
Usage: katello [options]

katello: error: Option --org is required; please see --help



I usually don't think about arg ordering as mattering, but it does in our CLI and we need better communication around that.

Comment 1 Lukas Zapletal 2012-05-15 08:47:32 UTC

*** This bug has been marked as a duplicate of bug 817845 ***