Bug 818688 - polipo service fails to start at boot
polipo service fails to start at boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: polipo (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 14:27 EDT by John C Peterson
Modified: 2012-07-11 19:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 19:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John C Peterson 2012-05-03 14:27:14 EDT
Description of problem: The polipo service fails to start (by systemd).


Version-Release number of selected component (if applicable): 1.0.4.1-6.fc17


How reproducible: 100% reproducible.


Steps to Reproduce:
1. Install the polipo package
2. Enable it with: "systemctl enable polipo.service"
3. Attempt to start it: "systemctl start polipo.service" (or reboot the system)


Actual results: The polipo service fails to start, from /var/log/messages;

May  3 10:24:40 kd6ekq systemd[1]: Failed to load environment files: No such file or directory
May  3 10:24:40 kd6ekq systemd[1]: polipo.service failed to run 'start' task: No such file or directory
May  3 10:24:40 kd6ekq systemd[1]: Unit polipo.service entered failed state.


Expected results: It should start.

Additional info: It looks to be caused by a couple of mistakes in the conversion form SYSV Init to systemd. In the file: /lib/systemd/system/polipo.service, note the two lines:

EnvironmentFile=/etc/sysconfig/polipo
ExecStart=/usr/sbin/polipo -c $CONFIG

1) The polipo package does NOT contain a file "/etc/sysconfig/polipo", probably just got left out by mistake

2) The ExecStart entry appears to be erroneous, there is no file named /usr/sbin/polipo (the polipo executable is packaged as /usr/bin/polipo)

I got it to work fine for me by making these changes;

1) I created a file "/etc/sysconfig/polipo" containing these two lines;
# Command line options for polipo
CONFIG=/etc/polipo/config

2) I corrected the error in /lib/systemd/system/polipo.service;
ExecStart=/usr/bin/polipo -c $CONFIG
Comment 1 Carl van Tonder 2012-05-17 14:42:12 EDT
Same version, same problem.

Cheers for your fine workaround, John.
Comment 2 Fedora Update System 2012-06-29 01:21:08 EDT
polipo-1.0.4.1-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/polipo-1.0.4.1-7.fc17
Comment 3 John C Peterson 2012-06-29 14:23:14 EDT
The updated package polipo-1.0.4.1-7.fc17 with fixes for this bug should be available shortly in fedora-updates-testing. As most people don't have the updates-testing repository enabled, use the --enablerepo command line option to temporarily enable it;

yum --enablerepo=updates-testing upgrade polipo
Comment 4 Fedora Update System 2012-06-30 18:11:33 EDT
Package polipo-1.0.4.1-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing polipo-1.0.4.1-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10128/polipo-1.0.4.1-7.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-07-11 19:52:41 EDT
polipo-1.0.4.1-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.