Bug 818707 - "network --device=link" in kickstart breaks boot
"network --device=link" in kickstart breaks boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-05-03 14:51 EDT by Kamil Páral
Modified: 2012-05-08 00:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: dracut-018-31.git20120504.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 00:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-05-03 14:51:23 EDT
Description of problem:
First reported in bug 806931, then posted here.

$ virt-install --name AutoQA --ram 1024 --vcpus 1 --os-type linux --os-variant
fedora15 --disk path=/var/lib/libvirt/images/AutoQA.img,size=10 --location
http://dl.fedoraproject.org/pub/fedora/linux/development/17/i386/os/ --graphics
none --initrd-inject=/usr/share/autotest/tests/rats_install/fedora.ks
--extra-args "sshd serial console=ttyS0 ks=file:/fedora.ks"

[    5.924950] dracut Warning: 'method=' is deprecated. Using
'repo=http://dl.fedoraproject.org/pub/fedora/linux/development/17/i386/os/'
instead.
dracut Warning: 'method=' is deprecated. Using
'repo=http://dl.fedoraproject.org/pub/fedora/linux/development/17/i386/os/'
instead.
[    5.941403] dracut: anaconda: parsing kickstart /fedora.ks
[    6.602987] dracut: rd.luks=0: removing cryptoluks activation
[    6.623960] dracut: rd.lvm=0: removing LVM activation
[    6.656924] dracut: FATAL: Please supply bootdev argument for multiple ip=
lines
[    6.659117] dracut: Refusing to continue


[    6.661050] dracut Warning: Signal caught!
dracut Warning: Signal caught!
[    6.663333] dracut Warning: dracut: FATAL: Please supply bootdev argument
for multiple ip= lines
dracut Warning: dracut: FATAL: Please supply bootdev argument for multiple ip=
lines
[    6.667672] dracut Warning: dracut: Refusing to continue
dracut Warning: dracut: Refusing to continue
[    6.670366] dracut Warning: /dev/root does not exist
dracut Warning: /dev/root does not exist

[    6.673621] Kernel panic - not syncing: Attempted to kill init!
[    6.675277] Pid: 1, comm: init Not tainted 3.3.4-1.fc17.i686 #1
[    6.676947] Call Trace:
[    6.677718]  [<c09201d8>] ? printk+0x2d/0x2f
[    6.678918]  [<c09200b4>] panic+0x81/0x178
[    6.680182]  [<c043b51f>] do_exit+0x7ff/0x800
[    6.681443]  [<c043b7b4>] do_group_exit+0x34/0xa0
[    6.682763]  [<c043b838>] sys_exit_group+0x18/0x20
[    6.684102]  [<c0928074>] syscall_call+0x7/0xb


Will Woods' comment:

I'm 98% sure this is caused by a bug in dracut, which should be fixed by this
patch: http://article.gmane.org/gmane.linux.kernel.initramfs/2639

* Using a kickstart with "network --device=link" causes parse-kickstart to
write "ip=..." args to /etc/cmdline.d, then unset CMDLINE
* The bug with _getcmdline causes the "ip=..." arg to get duplicated
* "getargs ip=" returns the duplicated "ip=..." args, and then the network
module dies with the "Please supply bootdev argument for multiple ip= lines"
error.
Comment 1 Kamil Páral 2012-05-03 14:52:50 EDT
See attachment 573018 [details] to see the kickstart used.

Proposing as NTH. A lot of existing kickstarts may be broken and we can't fix
this with an update after final release.
Comment 2 Fedora Update System 2012-05-04 07:23:30 EDT
dracut-018-31.git20120504.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dracut-018-31.git20120504.fc17
Comment 3 Kamil Páral 2012-05-04 10:04:33 EDT
How can I test this? dracut is part of initrd.img, right? How can I build it from updates-testing?
Comment 4 Tim Flink 2012-05-04 13:36:44 EDT
(In reply to comment #3)
> How can I test this? dracut is part of initrd.img, right? How can I build it
> from updates-testing?

Either build a test iso or wait for the next compose that includes it - that will include the new dracut in the initrd.
Comment 5 Adam Williamson 2012-05-04 13:42:29 EDT
Discussed at 2012-05-04 NTH review meeting. Seems to break significant kickstart functionality (choice of network device), so accepted as NTH.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Fedora Update System 2012-05-04 18:17:12 EDT
Package dracut-018-31.git20120504.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-018-31.git20120504.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7315/dracut-018-31.git20120504.fc17
then log in and leave karma (feedback).
Comment 7 Kamil Páral 2012-05-07 05:25:40 EDT
In F17 TC3 this seems fixed.
Comment 8 Fedora Update System 2012-05-08 00:16:49 EDT
dracut-018-31.git20120504.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.