Bug 818711 - incorrectly determining available release versions for systems to choose from
incorrectly determining available release versions for systems to choose from
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
SAM QE List
: Triaged
Depends On: sam11-tracker
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 14:54 EDT by Tom McKay
Modified: 2013-06-07 13:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 13:18:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tomckay: automate_bug?


Attachments (Terms of Use)
check available system version to choose from . (157.87 KB, image/png)
2012-05-09 03:20 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tom McKay 2012-05-03 14:54:29 EDT
The available release versions for headpin must be pulled from the CDN, not the repositories in the Library environment (as katello would do).
Comment 1 Tom McKay 2012-05-07 08:32:50 EDT
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 7dc0c050ae3d33e1c6d0ecbab2ae96b3271a4ae1
      https://github.com/Katello/katello/commit/7dc0c050ae3d33e1c6d0ecbab2ae96b3271a4ae1
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-05-04 (Fri, 04 May 2012)

To test, import a manifest and note the available release choices on the System/Details page
Comment 3 Tazim Kolhar 2012-05-09 03:20:43 EDT
Created attachment 583169 [details]
check available system version to choose from .

VERIFIED using the build :

[root@dhcp201-156 ~]# rpm -qa | grep katello
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-common-0.3.1-1.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
katello-cli-common-0.3.2-2.el6_2.noarch
katello-configure-0.3.3-1.el6_2.noarch
katello-headpin-all-0.2.6-3.el6_2.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-headpin-0.2.6-3.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch

Note You need to log in before you can comment on or make changes to this bug.