Bug 818712 - log messages for configuration errors should be more clear
log messages for configuration errors should be more clear
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Dan Kenigsberg
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 14:54 EDT by Dennis Jacobfeuerborn
Modified: 2013-02-03 07:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-03 07:25:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2012-05-03 14:54:44 EDT
On the mailing list a user had a problem that resulted in the following log message:

MainThread::DEBUG::2012-05-03 11:22:33,866::vdsm-reg-setup::73::root::validate end. return: False

According to Doron Fediuck this means there is an error in the configuration file /etc/vdsm-reg/vdsm-reg.conf [1] but for a regular user this is not really clear from the log message.

The message should contain a clear hint that this is a configuration issue. Also it seems this is only logged as a DEBUG message when a broken configuration should really result in an ERROR or at least in a WARNING.


[1] http://lists.ovirt.org/pipermail/users/2012-May/001866.html
Comment 1 Itamar Heim 2013-02-03 07:25:29 EST
Closing old bugs. If this issue is still relevant/important in current version, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.