Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 818718 - Review Request: drupal6-fivestar - Five Star Module for Drupal6
Summary: Review Request: drupal6-fivestar - Five Star Module for Drupal6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Wesley Hearn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-03 19:02 UTC by Anderson Silva
Modified: 2013-03-23 12:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-26 22:07:53 UTC
Type: ---
whearn: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Anderson Silva 2012-05-03 19:02:30 UTC
Spec URL: http://people.redhat.com/~ansilva/drupal6-fivestar-1.20-1.fc16.src.rpm
SRPM URL:  http://people.redhat.com/~ansilva/drupal6-fivestar.spec
Description: Adds a clean, attractive voting widget to nodes  in Drupal

Comment 1 Wesley Hearn 2012-05-09 16:31:41 UTC
[OK] MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.
  Fedora 16 Mock:
  [12:18 PM]
  [0]whearn@Desktop:/var/lib/mock/fedora-16-x86_64/result $ rpmlint drupal6-fivestar-1.20-1.fc16.*
  2 packages and 0 specfiles checked; 0 errors, 0 warnings.
  
  Fedora 17 Mock:
  [12:19 PM]
  [0]whearn@Desktop:/var/lib/mock/fedora-17-x86_64/result $ rpmlint drupal6-fivestar-1.20-1.fc17.*
  2 packages and 0 specfiles checked; 0 errors, 0 warnings.
  
  RHEL 6 Mock:
  [12:20 PM]
  [0]whearn@Desktop:/var/lib/mock/epel-6-x86_64/result $ rpmlint drupal6-fivestar-1.20-1.el6.*
  2 packages and 0 specfiles checked; 0 errors, 0 warnings.


[OK] MUST: The package must be named according to the Package Naming Guidelines .
[OK] MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption. 
[OK] MUST: The package must meet the Packaging Guidelines .
[OK] MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines .
[OK] MUST: The License field in the package spec file must match the actual license. 
[SHOULD] MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
[OK] MUST: The spec file must be written in American English. 
[OK] MUST: The spec file for the package MUST be legible. 
[OK] MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use md5sum for this task. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.
  [12:04 PM]
  [0]whearn@Desktop:~/rpmbuild/SOURCES $ md5sum fivestar-6.x-1.20.tar.gz 
  b94b84f96c0c5ebeb9440c3fb1bdbbff  fivestar-6.x-1.20.tar.gz
  [12:05 PM]
  [0]whearn@Desktop:~/rpmbuild/SOURCES $ curl http://ftp.drupal.org/files/projects/fivestar-6.x-1.20.       ↳ tar.gz | md5sum -
    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                   Dload  Upload   Total   Spent    Left  Speed
  100 78492  100 78492    0     0   147k      0 --:--:-- --:--:-- --:--:--  196k
  b94b84f96c0c5ebeb9440c3fb1bdbbff  -

[OK] MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture. 
[OK] MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line. 
[OK] MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.
[OK] MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.
[OK] MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun. 
[OK] MUST: Packages must NOT bundle copies of system libraries.
[OK] MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker. 
[OK] MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory. 
[OK] MUST: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)
[OK] MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example. 
[OK] MUST: Each package must consistently use macros. 
[OK] MUST: The package must contain code, or permissable content. 
[OK] MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity). 
[OK] MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present. 
[OK] MUST: Static libraries must be in a -static package. 
[OK] MUST: Development files must be in a -devel package. 
[OK] MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release} 
[OK] MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.
[OK] MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation. 
[OK] MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time. 
[OK] MUST: All filenames in rpm packages must be valid UTF-8.

[!!] SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it. 
[OK] SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available. 
[OK] SHOULD: The reviewer should test that the package builds in mock. 
[OK] SHOULD: The package should compile and build into binary rpms on all supported architectures. 
[OK] SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.
[OK] SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity. 
[OK] SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency. 
[OK] SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb. 
[OK] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself. 
[OK] SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.[

I flaged that should due to the address having been changed. As with all the others send in a bug report about it.

Since that is only should the package passes.

Comment 2 Anderson Silva 2012-05-09 21:20:42 UTC
New Package SCM Request
=======================
Package Name: drupal6-fivestar
Short Description: Adds a clean, attractive voting widget to nodes  in Drupal6
Owners: afsilva
Branches: f16 f17 el6

Comment 3 Gwyn Ciesla 2012-05-10 12:29:18 UTC
Git done (by process-git-requests).

Comment 4 Fedora Update System 2012-05-10 19:33:10 UTC
drupal6-fivestar-1.20-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/drupal6-fivestar-1.20-2.el6

Comment 5 Fedora Update System 2012-05-10 19:37:15 UTC
drupal6-fivestar-1.20-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/drupal6-fivestar-1.20-2.fc16

Comment 6 Fedora Update System 2012-05-10 19:38:29 UTC
drupal6-fivestar-1.20-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/drupal6-fivestar-1.20-2.fc17

Comment 7 Fedora Update System 2012-05-11 10:28:55 UTC
drupal6-fivestar-1.20-2.fc16 has been pushed to the Fedora 16 testing repository.

Comment 8 Fedora Update System 2012-05-26 22:07:53 UTC
drupal6-fivestar-1.20-2.el6 has been pushed to the Fedora EPEL 6 stable repository.

Comment 9 Fedora Update System 2012-06-07 02:36:51 UTC
drupal6-fivestar-1.20-2.fc17 has been pushed to the Fedora 17 stable repository.

Comment 10 Shawn Iwinski 2013-03-23 05:13:49 UTC
Package Change Request
======================
Package Name: drupal6-fivestar
New Branches: el5
Owners: ansilva siwinski
InitialCC: 

Adding el5 branch to follow most other drupal6 packages.

Comment 11 Gwyn Ciesla 2013-03-23 12:56:17 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.