Bug 818748 - file not found messages logged during hard drive install of F16
file not found messages logged during hard drive install of F16
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 16:33 EDT by MJH
Modified: 2013-02-13 13:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 13:55:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install.log (114.51 KB, application/octet-stream)
2012-05-03 16:33 EDT, MJH
no flags Details
/root/anaconda-ks.cfg (3.88 KB, text/plain)
2012-05-04 16:06 EDT, MJH
no flags Details

  None (edit)
Description MJH 2012-05-03 16:33:11 EDT
Created attachment 581957 [details]
install.log

file not found messages logged during hard drive install of F16.

I used the following old-grub stanza to perform a custom fresh install of F16:
title Install Fedora16 from iso 11 15:34
	root (hd1,2)
	kernel /isolinux16/vmlinuz repo=hd:LABEL=/home1:/iso16 acpi=off processor.nocst=1 maxcpus=1 selinux=0
	initrd /isolinux16/initrd.img

Everything seemed to go smoothly, however:
[root@localhost ~]# grep -v stall install.log
warning: fontpackages-filesystem-1.44-2.fc15.noarch: Header V3 RSA/SHA256
Signature, key ID a82ba4b7: NOKEY
/var/tmp/rpm-tmp.70BdJf: line 1: /usr/sbin/update-alternatives: No such file
or directory warning: %post(tomcat-servlet-3.0-api-0:7.0.26-1.fc16.noarch)
scriptlet failed, exit status 127 /var/tmp/rpm-tmp.pKiL8w: line 1:
/usr/sbin/update-alternatives: No such file or directory warning:
%post(tomcat-jsp-2.2-api-0:7.0.26-1.fc16.noarch) scriptlet failed, exit
status 127 /var/tmp/rpm-tmp.NaLh0X: line 3: find: command not found
/var/tmp/rpm-tmp.hawg7Q: line 1: /usr/sbin/update-alternatives: No such file
or directory warning: %post(tomcat-el-2.2-api-0:7.0.26-1.fc16.noarch)
scriptlet failed, exit status 127 Running in chroot, ignoring request.
SELinux:  Could not downgrade policy file
/etc/selinux/targeted/policy/policy.26, searching for an older version.
SELinux:  Could not open policy file <=
/etc/selinux/targeted/policy/policy.26:  No such file or directory
load_policy:  Can't load policy:  No such file or directory
6874 blocks
*** FINISHED INSTALLING PACKAGES ***


getenforce says Disabled, I expect because of the above Could nots.

All the complained of files exist.

I've attached install.log .

I'm reluctant to try to reproduce the bug.
Getting F16 installed at all was a long hard-fought struggle.
I've a pentium 4 CPU on a D865GBF motherboard.
Comment 1 Daniel Walsh 2012-05-04 07:23:50 EDT
Did you have the selinux-policy-targeted package installed?   I would guess this message can be ignored.  Since you have SELinux disabled.

If a package tried to do an SELinux activity on a disabled machine and selinux-policy-targeted package was not installed, you could see a message like this, although I am not sure what it is doing.  If you look at tomcat-jsb package, is it doing SELinux stuff in its post install?

rpm -q --script tomcat-jsb
Comment 2 MJH 2012-05-04 16:06:24 EDT
Created attachment 582203 [details]
/root/anaconda-ks.cfg
Comment 3 MJH 2012-05-04 16:18:24 EDT
SELinux is not disabled by design.  I tried to take the defaults.

yum and rpm say that selinux-policy-targeted is installed.
selinux-policy-targeted-3.10.0-80.fc16.noarch

Here is the requested script.  rpm is fussy about spelling.

[root@localhost ~]# rpm -q --scripts tomcat-jsp-2.2-api
postinstall scriptlet (using /bin/sh):
/usr/sbin/update-alternatives --install /usr/share/java/jsp.jar jsp \
    /usr/share/java/tomcat-jsp-2.2-api.jar 20200
postuninstall scriptlet (using /bin/sh):
if [ "$1" = "0" ]; then
    /usr/sbin/update-alternatives --remove jsp \
        /usr/share/java/tomcat-jsp-2.2-api.jar
fi
[root@localhost ~]# rpm -q --scripts tomcat-jsvc
package tomcat-jsvc is not installed

yum info '*alternatives*'

tells me that galternatives is available, but not installed.
Comment 4 Fedora End Of Life 2013-01-16 10:45:28 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora End Of Life 2013-02-13 13:55:19 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.