Bug 818753 - Bump up to latest upstream release
Bump up to latest upstream release
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jline2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 16:43 EDT by Roman Kennke
Modified: 2013-02-01 06:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 06:11:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JLine 2.6 patch (4.36 KB, patch)
2012-05-03 16:43 EDT, Roman Kennke
no flags Details | Diff

  None (edit)
Description Roman Kennke 2012-05-03 16:43:22 EDT
Created attachment 581958 [details]
JLine 2.6 patch

The attached patch brings the package up to latest upstream release. Please apply if you think it's good. I need it for Thermostat package, would be great to also bring it into F17 if possible. Thanks!
Comment 1 Roman Kennke 2012-05-03 17:00:17 EDT
I just realized I can change Thermostat to use the 2.5 release for now. There seem to be some non-compatible changes in ConsoleReader constructor, which might break dependend packages. (Consider this for F18.)
Comment 2 Bohuslav "Slavek" Kabrda 2013-01-24 04:09:17 EST
Hi, I'm starting to update packages needed for new JRuby (see JRuby 1.7 feature [1]). The new JRuby needs at least jline 2.8, but the latest upstream would be optimal.

Could you please update?
Thanks.


[1] https://fedoraproject.org/wiki/Features/JRuby_1.7
Comment 3 Marek Goldmann 2013-02-01 06:11:55 EST
Upgraded to 2.10 in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.