Bug 818763 - [abrt] firefox-12.0-1.fc16: release: Process /usr/lib64/firefox/firefox was killed by signal 7 (SIGBUS)
Summary: [abrt] firefox-12.0-1.fc16: release: Process /usr/lib64/firefox/firefox was k...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3d3fece45e42f362fb666d982d9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-05-03 21:49 UTC by Mr. Meval
Modified: 2012-07-31 14:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-31 14:44:39 UTC
Type: ---


Attachments (Terms of Use)
File: environ (4.21 KB, text/plain)
2012-05-03 21:49 UTC, Mr. Meval
no flags Details
File: dso_list (19.83 KB, text/plain)
2012-05-03 21:49 UTC, Mr. Meval
no flags Details
File: build_ids (8.05 KB, text/plain)
2012-05-03 21:49 UTC, Mr. Meval
no flags Details
File: maps (94.81 KB, text/plain)
2012-05-03 21:49 UTC, Mr. Meval
no flags Details
File: backtrace (112.91 KB, text/plain)
2012-05-03 21:49 UTC, Mr. Meval
no flags Details

Description Mr. Meval 2012-05-03 21:49:47 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/firefox/firefox
crash_function: release
executable:     /usr/lib64/firefox/firefox
kernel:         3.3.2-6.fc16.x86_64
pid:            17644
reason:         Process /usr/lib64/firefox/firefox was killed by signal 7 (SIGBUS)
time:           Thu 03 May 2012 05:44:24 PM EDT
uid:            500

backtrace:      Text file, 115620 bytes
build_ids:      Text file, 8241 bytes
dso_list:       Text file, 20302 bytes
environ:        Text file, 4316 bytes
maps:           Text file, 97084 bytes

comment:
:On facebook and tried to open a notification in a new tab.
:
:If this is going to automatically be closed I will stop submitting these. They're not from some automaton I had to configure my system to properly generate them and had to take the time. 

smolt_data:
:
:
:General
:=================================
:UUID: ccb9c23a-29d9-4e03-9b47-6d176c108212
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6829.69
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Phenom(tm) II X4 965 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 4
:Number of CPUs: 4
:CPU Speed: 3400
:System Memory: 7986
:System Swap: 10047
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.2-6.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17296:4163:33859) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
:(4130:38409:4163:33854) pci, pcieport, PCI/PCI, RS780/RS880 PCI to PCI bridge (PCIE port 5)
:(4098:43568:4098:43568) pci, snd_hda_intel, MULTIMEDIA, HD48x0 audio
:(4130:38401:4163:33854) pci, None, HOST/PCI, M5A88-V EVO
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:38403:4163:33854) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (ext gfx port 0)
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4098:17312:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 0)
:(4098:17313:4098:0) pci, pcieport, PCI/PCI, SB700/SB800 PCI to PCI bridge (PCIE port 1)
:(4098:17308:4163:33859) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4163:33859) pci, None, PCI/ISA, M5A88-V EVO
:(4098:17283:4163:33819) pci, snd_hda_intel, MULTIMEDIA, M5A88-V EVO
:(4098:17305:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:37952:4098:1282) pci, radeon, VIDEO, RV770 [Radeon HD 4870]
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4147:404:4163:33811) pci, xhci_hcd, USB, P8P67 Deluxe Motherboard
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_tower-lv_root / ext4 4096 4096 193715952 180429375 180298347 49152000 48335551 48335551
:/dev/sdb2 /boot ext4 1024 1024 508745 410065 384465 128016 127779 127779
:/dev/sdd1 WITHHELD ext4 4096 4096 130933269 14820078 8266478 32768000 32766406 32766406
:/dev/sdd3 WITHHELD ext4 4096 4096 130933269 76633713 70080113 32768000 32744382 32744382
:/dev/sdd2 WITHHELD ext4 4096 4096 130933205 117328423 110774828 32768000 32642604 32642604
:/dev/sdd4 WITHHELD ext4 4096 4096 95057342 77084774 72326658 23797760 22868827 22868827
:/dev/mapper/vg_tower-lv_home /home ext4 4096 4096 179352408 145075173 136098380 44883968 44727491 44727491
:

var_log_messages:
:May  3 17:44:24 tower kernel: [53333.994684] firefox[17644] trap stack segment ip:7f2e593fa1f8 sp:7fff7f884a00 error:0
:May  3 17:44:29 tower abrt[17703]: Saved core dump of pid 17644 (/usr/lib64/firefox/firefox) to /var/spool/abrt/ccpp-2012-05-03-17:44:24-17644 (462712832 bytes)

Comment 1 Mr. Meval 2012-05-03 21:49:50 UTC
Created attachment 581971 [details]
File: environ

Comment 2 Mr. Meval 2012-05-03 21:49:52 UTC
Created attachment 581972 [details]
File: dso_list

Comment 3 Mr. Meval 2012-05-03 21:49:54 UTC
Created attachment 581973 [details]
File: build_ids

Comment 4 Mr. Meval 2012-05-03 21:49:56 UTC
Created attachment 581974 [details]
File: maps

Comment 5 Mr. Meval 2012-05-03 21:49:59 UTC
Created attachment 581975 [details]
File: backtrace

Comment 6 Martin Stransky 2012-05-04 05:59:41 UTC
Hm, it looks like a hardware failure. Does it crash regularly to you?

Comment 8 Mr. Meval 2012-05-04 19:58:57 UTC
You can close this. I'll try and figure out how to submit the way mozilla wants.

Comment 9 Martin Stransky 2012-05-14 08:44:21 UTC
Reported, can you reproduce it reliably? If so, we can look into it.

Comment 10 Mr. Meval 2012-05-14 21:30:32 UTC
I will try and find out what is causing it and see. If you or the dev team have not seen this then it may be my hardware. I cannot decode any of that information to figure out what it might be. Thank you.

Comment 11 ant_978red 2012-05-28 01:54:04 UTC
I've experienced this bug as well.... firefox randomly segfaults; though it seems Iron and Opera do it too. 

The only data I get back from everything.log is:
May 27 21:44:37 localhost kernel: [ 8848.822727] firefox[1271] trap stack segment ip:7f7132bcd0ac sp:7fff81bc7b70 error:0

It seems to be related to having certain webpages open, but I don't know the cause of this :/

Comment 12 ant_978red 2012-05-28 08:13:33 UTC
(In reply to comment #11)
> I've experienced this bug as well.... firefox randomly segfaults; though it
> seems Iron and Opera do it too. 
> 
> The only data I get back from everything.log is:
> May 27 21:44:37 localhost kernel: [ 8848.822727] firefox[1271] trap stack
> segment ip:7f7132bcd0ac sp:7fff81bc7b70 error:0
> 
> It seems to be related to having certain webpages open, but I don't know the
> cause of this :/

Scratch that, I just ran memtest86+; looks like my ram is bad in a section...

Comment 13 Martin Stransky 2012-07-31 14:44:39 UTC
Okay, closing.


Note You need to log in before you can comment on or make changes to this bug.