Bug 818772 - [resource tree] Infinite auto-switching between auto-group nodes occurs after fast-clicking between two auto-group nodes
[resource tree] Infinite auto-switching between auto-group nodes occurs after...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.1.0
All All
urgent Severity low
: ---
: JON 3.1.1
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On: 827203
Blocks: rhq-uxd
  Show dependency treegraph
 
Reported: 2012-05-03 19:14 EDT by Viet Nguyen
Modified: 2013-09-11 06:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 827203 (view as bug list)
Environment:
Last Closed: 2013-09-11 06:58:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen video capture (990.54 KB, video/ogg)
2012-05-03 19:14 EDT, Viet Nguyen
no flags Details
JON 3.1 screen shot (66.79 KB, image/png)
2012-05-15 13:49 EDT, Viet Nguyen
no flags Details

  None (edit)
Description Viet Nguyen 2012-05-03 19:14:10 EDT
Description of problem:
After upgrading JON from 3.0.0 to 3.0.1 I re-inventoried and clicked back and forth between two JBoss server resources and got the UI into a loop.  See attached video.

Version-Release number of selected component (if applicable):
JON 3.0.1

How reproducible:


Steps to Reproduce:
1.  Install JON 3.0.0 with Jboss AS and JBoss AS5 plugin 
2.  Upgrade JON to 3.0.1
3.  Reinventory. Go to Plaftform and expand contents under JBoss AS servers plugin nodes
4.  Alternate a couple mouse clicks between the JBoss AS5 and JBoss AS node then stop.  
  
Actual results:
The UI will continue to switch back and forth between 2 nodes without user intervention

Expected results:


Additional info:
Comment 1 Viet Nguyen 2012-05-03 19:14:54 EDT
Created attachment 581984 [details]
screen video capture
Comment 2 Larry O'Leary 2012-05-08 14:21:41 EDT
Do you see this with a JON 3.1.0 build?
Comment 3 Jay Shaughnessy 2012-05-11 13:33:01 EDT
This definitely showed an issue, as you can see there were actually detached DOM elements as well, which is seen in that blotchy area above the JON logo.  Given large amounts of UI changes, though, I'd suggest we close this unless it can be reproduced with RHQ 4.4 or JON 3.1.

If this has only been seen with 3.0.1 please change the "Versions" field appropriately.
Comment 4 Viet Nguyen 2012-05-15 13:44:00 EDT
100% reproducible with 3.1.0 BETA. Expand CPUs and File Systems node. Then alternately click on CPUs, File systems in rapid succession.
Comment 5 Viet Nguyen 2012-05-15 13:49:35 EDT
Created attachment 584736 [details]
JON 3.1 screen shot
Comment 8 Ian Springer 2012-05-31 17:56:37 EDT
This is fixed in master (see bug 827203). This bug targets JON 3.1.1, so we need to wait until after JON 3.1.0 is released to cherry pick it to the release/jon3.1.x branch.
Comment 9 John Sanda 2012-08-02 14:52:00 EDT
JON 3.1.1 ER1 build is available. Moving to ON_QA.

https://brewweb.devel.redhat.com/buildinfo?buildID=226942
Comment 10 John Sanda 2012-08-02 16:32:31 EDT
Moving back to ON_DEV. This should not have been moved to ON_QA as noted in comment 9.
Comment 11 Jay Shaughnessy 2012-08-09 10:18:48 EDT
release/jon3.1.x commit 1e36d521827451188a255dba6bfd885b9a61fd7f

Conflicts:

    modules/enterprise/gui/coregui/src/main/java/org/rhq/enterprise/gui/coregui/client/inventory/resource/detail/ResourceTreeView.java

Cherry-pick master a92b7bcace3265964f87fb656b45cf3102ad8708
Comment 12 John Sanda 2012-08-13 22:16:39 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250
Comment 13 Filip Brychta 2012-08-21 10:58:22 EDT
Unable to reproduce on JON 3.1.1 ER2 -> verified

Note You need to log in before you can comment on or make changes to this bug.