Bug 818780 - No man page for oddjobd-mkhomedir.conf
No man page for oddjobd-mkhomedir.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.2
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Jan Chaloupka
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1119565
  Show dependency treegraph
 
Reported: 2012-05-03 20:46 EDT by Paul Pham
Modified: 2014-10-14 03:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: oddjobd-mkhomedir.conf man page was missing Consequence: man oddjobd-mkhomedir.conf failed Fix: missing man page added Result: man oddjobd-mkhomedir.conf succeeds
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Pham 2012-05-03 20:46:44 EDT
Description of problem:
Recently replaced pam_mkhomedir with oddjob-mkhomedir to work around the SELinux issues with pam_mkhomedir. There appear to be some general man pages for oddjobd and oddjobd.conf, but no documentation anywhere that I can find for how to configure oddjobd-mkhomedir.conf.

More specifically I was trying to figure out how to specify the skeleton directory in oddjobd-mkhomedir.conf, since you can't pass arguments via /etc/pam.d/password-auth like you could with pam_mkhomedir.

The man pages for pam_oddjob_mkhomedir explicitly tell you that you can't pass arguments directly to the module, but doesn't tell you how to pass them via oddjobd-mkhomedir.conf. Since I knew how this parameter was passed using the original pam_mkhomedir, I was able to guess correctly what the parameter should look like. But in my opinion this needs to be documented somewhere.

Another possible bug is that oddjobd-mkhomedir does not use /etc/skel as the default skeleton directory (pam_mkhomedir does). Not sure if this is the intended behavior, but this is the reason why I had to figure out how to pass the skel parameter to oddjobd-mkhomedir. It would be nice if this were more consistent.

Version-Release number of selected component (if applicable):
oddjob-mkhomedir-0.30-5.el6.x86_64

How reproducible:
It's a missing man page, should be 100% 

Steps to Reproduce:
If oddjob_mkhomedir is already installed:
1. man pam_oddjob_mkhomedir [works]
2. man oddjobd-mkhomedir.conf [does not work]
  
Actual results:
No manual entry for oddjobd-mkhomedir.conf


Expected results:
Even if there's no man page for this conf file specifically, there needs to be some documentation somewhere on how to pass arguments via oddjobd-mkhomedir.conf

Additional info:
Comment 2 RHEL Product and Program Management 2012-09-07 01:31:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2014-10-14 03:25:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html

Note You need to log in before you can comment on or make changes to this bug.