Bug 818800 - hostapd.service pointing to the wrong config file
hostapd.service pointing to the wrong config file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hostapd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 23:34 EDT by Izhar Firdaus
Modified: 2012-06-19 10:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 10:58:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Izhar Firdaus 2012-05-03 23:34:00 EDT
Description of problem:
hostapd.service pointing to the wrong config file path. the rpm installs the config in /etc/hostapd/hostapd.conf while hostapd.service is using /etc/hostapd.conf



Version-Release number of selected component (if applicable):
hostapd-0.7.3-5.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install hostapd
2. configure hostapd
3. start hostapd
  
Actual results:
fails to start

Expected results:
start successfully

Additional info:

hostapd.service is using:
ExecStart=/usr/sbin/hostapd /etc/hostapd.conf -P /run/hostapd.pid -B

should be
ExecStart=/usr/sbin/hostapd /etc/hostapd/hostapd.conf -P /run/hostapd.pid -B
Comment 1 Fedora Update System 2012-05-25 14:08:27 EDT
hostapd-0.7.3-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hostapd-0.7.3-6.fc17
Comment 2 Fedora Update System 2012-05-26 04:02:49 EDT
Package hostapd-0.7.3-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hostapd-0.7.3-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8421/hostapd-0.7.3-6.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-05-30 11:10:50 EDT
hostapd-0.7.3-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hostapd-0.7.3-7.fc17
Comment 4 Petr Tuma 2012-06-02 16:14:21 EDT
Tried hostapd-0.7.3-7.fc17, the config file location issue is fixed.

There is one more bug in /usr/lib/systemd/system/hostapd.service though.

The PIDFile entry says the PID file should be /run/hostapd/hostapd.pid, while the ExecStart entry in the same file says -P /run/hostapd.pid.
Comment 5 Fedora Update System 2012-06-06 14:02:59 EDT
hostapd-0.7.3-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hostapd-0.7.3-8.fc17
Comment 6 Petr Tuma 2012-06-07 14:35:50 EDT
Tested quickly, seems to work, thanks !
Comment 7 Trever Adams 2012-06-08 01:49:14 EDT
This does NOT fix the problem. It causes another. /run/hostapd is NOT created by a tmpfiles.d setup. It must be because hostapd doesn't create it itself until after you are trying to write a pid file to it.

So, one of two solutions exist. I do not know which is correct for Fedora policies:

1) Create /run/hostapd in a /etc/tmpfiles.d file
2) Change the PIDFile and -P part of command line to write/read to /run/hostapd.pid instead of /run/hostapd/hostapd.pid
Comment 8 Fedora Update System 2012-06-08 10:54:12 EDT
hostapd-0.7.3-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hostapd-0.7.3-9.fc17
Comment 9 Fedora Update System 2012-06-08 11:04:50 EDT
hostapd-0.7.3-9.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/hostapd-0.7.3-9.fc16
Comment 10 Trever Adams 2012-06-10 22:45:01 EDT
I believe this is correctly fixed.
Comment 11 Fedora Update System 2012-06-19 10:53:58 EDT
hostapd-0.7.3-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-06-19 10:58:14 EDT
hostapd-0.7.3-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.