Bug 818847 - Improve the output message when set --spice-color-depth in invalid value
Improve the output message when set --spice-color-depth in invalid value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 03:39 EDT by tingting zheng
Modified: 2013-02-21 03:47 EST (History)
11 users (show)

See Also:
Fixed In Version: spice-gtk-0.14-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:47:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0343 normal SHIPPED_LIVE spice-gtk bug fix and enhancement update 2013-02-20 15:53:54 EST

  None (edit)
Description tingting zheng 2012-05-04 03:39:39 EDT
Description of problem:
Improve the output message when set --spice-color-depth in invalid value.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Configure a guest with spice.
2. # virt-viewer --help-spice
……
  --spice-color-depth=<16,32>                    Guest display color depth
……

3. Use virt-viewer or remote-viewer with --spice-color-depth to open the guest.
# virt-viewer rhel6-spice --spice-color-depth=1
(virt-viewer:4224): GSpice-CRITICAL **: spice_main_set_property: assertion `color_depth % 8 == 0' failed

# virt-viewer rhel6-spice --spice-color-depth=-1
(virt-viewer:4265): GLib-GObject-WARNING **: value "-1" of type `gint' is invalid or out of range for property `color-depth' of type `gint'

(virt-viewer:4265): GLib-GObject-WARNING **: value "-1" of type `gint' is invalid or out of range for property `color-depth' of type `gint'

(virt-viewer:4265): GLib-GObject-WARNING **: value "-1" of type `gint' is invalid or out of range for property `color-depth' of type `gint'


Actual results:
When give a invalid value for --spice-color-depth,the message showed is not so clearly.

Expected results:
The messages showed should be more clearly,like:The value for --spice-color-depth should be <16,32>.

Additional info:
Comment 1 Daniel Berrange 2012-07-26 13:35:29 EDT
This command line argument is handled by the spice-client-gtk library, rather than virt-viewer
Comment 2 David Blechter 2012-07-27 13:11:13 EDT
It is not a bug, the invalid value was caught.
Comment 4 Christophe Fergeau 2012-08-10 11:53:05 EDT
I just sent a patch to fix this to the spice-devel mailing list:
http://lists.freedesktop.org/archives/spice-devel/2012-August/010378.html
Comment 9 errata-xmlrpc 2013-02-21 03:47:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0343.html

Note You need to log in before you can comment on or make changes to this bug.