Bug 818850 - virt-viewer connect to the remote guest with address=0.0.0.0 need twice authorization.
virt-viewer connect to the remote guest with address=0.0.0.0 need twice autho...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.4
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 04:05 EDT by Daisy Wu
Modified: 2012-05-04 05:06 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 05:06:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
debug-info (4.10 KB, text/plain)
2012-05-04 04:06 EDT, Daisy Wu
no flags Details

  None (edit)
Description Daisy Wu 2012-05-04 04:05:28 EDT
Description of problem:
virt-viewer connect to the remote guest with address=0.0.0.0 need twice authorization.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-6.el6.x86_64
libvirt-0.9.10-16.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. prepared local host and remote host.
2. prepared a remote guest with address=0.0.0.0
    # virsh dumpxml T1
    ...
    <graphics type='vnc' port='5900' autoport='yes' listen='0.0.0.0'>
      <listen type='address' address='0.0.0.0'/>
    </graphics>
    ...  
3. logon on local host, lauch virt-viewer to connect the remote guest.
   # virt-viewer -c qemu+ssh://10.66.5.65/system T1
   root@10.66.5.65's password:
   root@10.66.5.65's password:

4. through twice authorization, virt-viewer display the remote guest.

Actual results
As above

Expected results
virt-viewer can display the remote guest with address=0.0.0.0 by only once authorization.
Comment 1 Daisy Wu 2012-05-04 04:06:23 EDT
Created attachment 582049 [details]
debug-info
Comment 3 Daniel Berrange 2012-05-04 05:06:46 EDT
You need to authenticate once to connect to libvirt & once to connect to VNC since you requested SSH tunnelling.

If you want to avoid the SSH tunnelling for VNC, then pass the '--direct' flag.

Note You need to log in before you can comment on or make changes to this bug.