Bug 818868 - [Web UI] Host detail page is not filled with data
[Web UI] Host detail page is not filled with data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 04:40 EDT by Martin Kosek
Modified: 2012-06-20 09:27 EDT (History)
5 users (show)

See Also:
Fixed In Version: ipa-2.2.0-14.el6_3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:27:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kosek 2012-05-04 04:40:58 EDT
Description of problem:

When I go to a host detail page, all data fields for the host remain empty even though I see that the server sent the host data via JSON-RPC interface.

I could reproduce this issue for any host.

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-12.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Open a host detail page for random host
2.
3.
  
Actual results:
No host data is filled to the page data fields

Expected results:
Host page is successfully filled with data

Additional info:
We may want to also check other detail pages.
Comment 2 Martin Kosek 2012-05-04 05:04:47 EDT
I reproduced the bug in upstream code as well, it can be only reproduced when IPA is installed _without_ DNS support.
Comment 3 Martin Kosek 2012-05-04 05:06:30 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2728
Comment 4 Namita Soman 2012-05-11 14:43:53 EDT
Steps taken to see this issue described above:
1. Install ipa server with no dns
2. Go to UI - Hosts
3. Edit the ipa server host

Actual:
All fields are blank. No ssh keys.
Also as described in https://fedorahosted.org/freeipa/ticket/2747 : In Enrollment section, there is a grey box next to One Time password, instead of "Set OTP".

Expected:
Values to be filled in
Comment 5 Petr Vobornik 2012-05-15 06:55:14 EDT
Fixed upstream

ipa-2-2: 2c362c9079c004533bceeb55556afc6fd8a0e930

master: 69877296dc9da05e89a8f2585165becc7bbd9c99
Comment 9 Namita Soman 2012-05-16 14:27:16 EDT
Verified using ipa-server-2.2.0-14.el6.x86_64
Followed steps above, and can see data in Hosts page, no grey box anymore
Comment 11 errata-xmlrpc 2012-06-20 09:27:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.