Bug 818869 - cannot setup acl for ib_srpt with targetcli
cannot setup acl for ib_srpt with targetcli
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: targetcli (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Andy Grover
Fedora Extras Quality Assurance
:
Depends On: 826817
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 04:41 EDT by Albert Strasheim
Modified: 2012-06-07 11:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 11:21:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2012-05-04 04:41:13 EDT
Description of problem:

I can't seem to configure ACLs for ib_srpt with targetcli.

I followed this guide:

http://serverfault.com/questions/327947/set-up-simple-infiniband-block-storage-srp-or-iser

I reach a setup that looks like this:

/> ls
o- / .................................................................. [...]
  o- backstores ....................................................... [...]
  | o- block ............................................. [1 Storage Object]
  | | o- zero ................................. [/dev/mapper/zero1 activated]
  | o- fileio ............................................ [0 Storage Object]
  | o- pscsi ............................................. [0 Storage Object]
  | o- ramdisk ........................................... [0 Storage Object]
  o- ib_srpt ..................................................... [1 Target]
  | o- 0xfe800000000000000002c9030010df81 ......................... [enabled]
  |   o- acls ....................................................... [0 ACL]
  |   o- luns ....................................................... [1 LUN]
  |     o- lun0 ............................ [block/zero (/dev/mapper/zero1)]
  o- iscsi ....................................................... [0 Target]
  o- loopback .................................................... [0 Target]
  o- qla2xxx .................................................... [Not found]
  o- tcm_fc ..................................................... [Not found]

I try to setup the ACL:

/> cd /ib_srpt/0xfe800000000000000002c9030010df81/acls
/ib_srpt/0xfe...0010df81/acls> create fe800000000000000002c9030010e951
Created Node ACL for fe800000000000000002c9030010e951
Created mapped LUN 0.
/ib_srpt/0xfe...0010df81/acls> ls
Cannot find attribute: authentication.
/ib_srpt/0xfe...0010df81/acls> cd ..
/ib_srpt/0xfe...2c9030010df81> ls
Cannot find attribute: authentication.
/ib_srpt/0xfe...2c9030010df81> cd /
/> ls
Cannot find attribute: authentication.

targetcli is trying to read a file:

20715 stat("/sys/kernel/config/target/srpt/0xfe800000000000000002c9030010df81/tpgt_1/attrib/authentication", 0x7fffc214e3e0) = -1 ENOENT (No such file or directory)

/sys/kernel/config/target/srpt/0xfe800000000000000002c9030010df81/tpgt_1/attrib only contains:

srp_max_rdma_size srp_max_rsp_size srp_sq_size

i.e., no authentication file.

Version-Release number of selected component (if applicable):

kernel 3.3.2-6.fc16.x86_64

targetcli version reports 2.0rc1.fb8 but actually I have fb11. I notice that
the package has:

/usr/lib/python2.7/site-packages/targetcli-2.0rc1.fb8-py2.7.egg-info

but also

/usr/share/doc/targetcli-2.0rc1.fb11/README

How reproducible:

Always
Comment 1 Mark Rustad 2012-05-31 12:25:18 EDT
I see the exact same problem when using the tom_fc module on Fedora 17.
Comment 3 Andy Grover 2012-06-06 20:03:52 EDT
Albert this work for you now?
Comment 4 Albert Strasheim 2012-06-07 08:37:35 EDT
Works for me, thanks.

Any chance you could also take a look at bug 818855?

Note You need to log in before you can comment on or make changes to this bug.