Bug 818883 - Maven2 package crippled
Maven2 package crippled
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: maven2 (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Yong Yang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 05:21 EDT by Kaare Fiedler Christiansen
Modified: 2012-05-26 03:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 05:51:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaare Fiedler Christiansen 2012-05-04 05:21:58 EDT
Description of problem:

Most of the maven2 package has been removed, and what remains is not enough to use maven2 to build projects. For instance, the actual "mvn2" command has been removed.

I assume this has been done intentionally, but it makes it difficult to use Fedora for developing software that uses Maven 2. You need to install Maven 2 yourself.

At the very least, the current description of the Maven 2 package is wrong, and so are all the dependencies in the package.

The package in it's current form should be removed or renamed. To me a better solution would be to roll back to the previous version of maven2.

Version-Release number of selected component (if applicable):

maven2-2.2.1-32.fc17

How reproducible:

Completely. Try 
$ rpm -ql maven2.

Steps to Reproduce:
1. Install maven2
2. Type mvn2 at a shell
  
Actual results:

bash: mvn2: command not found...
Similar command is: 'mvn'

Expected results:

Maven 2 starts.

Additional info:
Comment 1 Alexander Kurtakov 2012-05-04 05:51:22 EDT
Maven 2 was stripped down because of insufficient number of packagers working on the stack. This allowed the current maintainers to remove a number of obsolete packages plexus* and others. This resulted in more resources being spend on Maven 3 and having better maven 3 in general. Maven2 package is kept because some of the libraries coming from it are still needed in Maven3 land.
It is not as simple as reverting a patch we speak about maintaining a dozen of other packages, some of them are so old that can't even be build with Java 7 which is the only working jvm in Fedora 17. If someone is willing to revive all these packages and port them when needed to build against Java 7 he is more than welcome.
Anyway, until such person appears this won't happen so the bug is closed as wontfix. And if someone wants to do that he should start by submitting package reviews for the old dropped libraries which don't have place in this bug too.
Comment 2 Kaare Fiedler Christiansen 2012-05-04 15:23:39 EDT
I understand you can't maintain a package due to lack of resources. But *please* retire the package with the name of maven2 (e.g. replace it with a package called maven2-bare that obsoletes maven2), or at least update it's description and dependencies. 

As it stands it is very confusing that installing the package "maven2" won't actually allow you to compile packages with maven2. And the list of dependencies for the maven2 package make absolutely no sense now.
Comment 3 Stanislav Ochotnicky 2012-05-09 09:40:16 EDT
Very well, you have a point. I've completely removed maven2 binary rpm in rawhide now. If nothing breaks too bad (I don't think it will), I intend to push this to F17 as well.
Comment 4 Fedora Update System 2012-05-11 05:17:05 EDT
maven2-2.2.1-33.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/maven2-2.2.1-33.fc17
Comment 5 Fedora Update System 2012-05-26 03:30:45 EDT
maven2-2.2.1-33.fc17, maven-3.0.4-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.