Bug 818891 - mirroring to stable iscsi path names (with colons) fails
mirroring to stable iscsi path names (with colons) fails
Status: CLOSED DUPLICATE of bug 818876
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
: TestOnly
Depends On: 818876
Blocks: 806280
  Show dependency treegraph
 
Reported: 2012-05-04 05:58 EDT by Shaolong Hu
Modified: 2012-05-11 07:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 10:26:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2012-05-04 05:58:32 EDT
Description of problem:
-------------------------
after mirroring with iscsi, i/o error, guest stopped.


Version-Release number of selected component (if applicable):
--------------------------------------------------------------
qemu-kvm-rhev-0.12.1.2-2.288.el6.x86_64


How reproducible:
-----------------
1/1


Steps to Reproduce:
--------------------
1.boot guest with lun 1:

-drive file=/dev/disk/by-path/ip-10.66.9.64\:3260-iscsi-iqn.2001-04.com.example\:storage.disk1.amiens.sys1.xyz-lun-1,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0

[root@shu ~]# lsof -a -p 31654 | grep dev
qemu-kvm 31654 root  DEL    REG                0,4               235845 /dev/zero
qemu-kvm 31654 root  DEL    REG                0,4               235826 /dev/zero
qemu-kvm 31654 root    0u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    1u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    2u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    7u   CHR             10,232         0t0    11828 /dev/kvm
qemu-kvm 31654 root   11u   CHR             10,200         0t0     9192 /dev/net/tun
qemu-kvm 31654 root   12u   BLK               8,16 0x1c0000000   235632 /dev/sdb


2.create a snapshot to lun 2:

(qemu) snapshot_blkdev drive-virtio-disk0 /dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-2 qcow2

(qemu) info block
drive-virtio-disk0: removable=0 io-status=ok file=/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-2 backing_file=/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-1 ro=0 drv=qcow2 encrypted=0

[root@shu ~]# lsof -a -p 31654 | grep dev
qemu-kvm 31654 root  DEL    REG                0,4               235845 /dev/zero
qemu-kvm 31654 root  DEL    REG                0,4               235826 /dev/zero
qemu-kvm 31654 root    0u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    1u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    2u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    7u   CHR             10,232         0t0    11828 /dev/kvm
qemu-kvm 31654 root   11u   CHR             10,200         0t0     9192 /dev/net/tun
qemu-kvm 31654 root   12u   BLK               8,16 0x1c0000000   235632 /dev/sdb
qemu-kvm 31654 root   23u   BLK               8,32 0x1c0000000   235635 /dev/sdc


3.mirroring to lun 3:

{ "execute" : "__com.redhat_drive-mirror", "arguments" : { "device" : "drive-virtio-disk0", "target" : "/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-3", "format": "qcow2", "mode": "absolute-paths", "full" : true } }
{"return": {}}

[root@shu ~]# lsof -a -p 31654 | grep dev
qemu-kvm 31654 root  DEL    REG                0,4               235845 /dev/zero
qemu-kvm 31654 root  DEL    REG                0,4               235826 /dev/zero
qemu-kvm 31654 root    0u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    1u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    2u   CHR              136,0         0t0        3 /dev/pts/0
qemu-kvm 31654 root    7u   CHR             10,232         0t0    11828 /dev/kvm
qemu-kvm 31654 root   11u   CHR             10,200         0t0     9192 /dev/net/tun
qemu-kvm 31654 root   12u   BLK               8,16 0x1c0000000   235632 /dev/sdb
qemu-kvm 31654 root   23u   BLK               8,32 0x1c0000000   235635 /dev/sdc
qemu-kvm 31654 root   25u   BLK               8,48 0x1c0000000   235639 /dev/sdd


4.after steady state, reopen to lun 3:

{ "execute": "__com.redhat_drive-reopen", "arguments": {"device": "drive-virtio-disk0", "new-image-file": "/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-3", "format": "qcow2" } }
{"timestamp": {"seconds": 1336123595, "microseconds": 260749}, "event": "BLOCK_JOB_COMPLETED", "data": {"device": "drive-virtio-disk0", "len": 7516192768, "offset": 7516192768, "speed": 0, "type": "mirror"}}
{"error": {"class": "OpenFileFailed", "desc": "Could not open '/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-2'", "data": {"filename": "/dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-2"}}}
{"timestamp": {"seconds": 1336123608, "microseconds": 86257}, "event": "BLOCK_IO_ERROR", "data": {"device": "drive-virtio-disk0", "__com.redhat_debug_info": {"message": "Input/output error", "errno": 5}, "__com.redhat_reason": "eio", "operation": "write", "action": "stop"}}
{"timestamp": {"seconds": 1336123608, "microseconds": 86567}, "event": "STOP"}

[root@shu ~]# lsof -a -p 31654 | grep dev
qemu-kvm 31654 root  DEL    REG                0,4            235845 /dev/zero
qemu-kvm 31654 root  DEL    REG                0,4            235826 /dev/zero
qemu-kvm 31654 root    0u   CHR              136,0      0t0        3 /dev/pts/0
qemu-kvm 31654 root    1u   CHR              136,0      0t0        3 /dev/pts/0
qemu-kvm 31654 root    2u   CHR              136,0      0t0        3 /dev/pts/0
qemu-kvm 31654 root    7u   CHR             10,232      0t0    11828 /dev/kvm
qemu-kvm 31654 root   11u   CHR             10,200      0t0     9192 /dev/net/tun

[root@shu ~]# ls /dev/disk/by-path/
ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-1  pci-0000:00:1f.2-scsi-0:0:0:0-part1
ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-2  pci-0000:00:1f.2-scsi-0:0:0:0-part2
ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-3  pci-0000:00:1f.2-scsi-2:0:0:0
pci-0000:00:1f.2-scsi-0:0:0:0                                                         



Additional info:
------------------
after the i/o error:

[root@shu ~]# qemu-img info /dev/sdb
image: /dev/sdb
file format: qcow2
virtual size: 7.0G (7516192768 bytes)
disk size: 0
cluster_size: 65536

[root@shu ~]# qemu-img info /dev/sdc
image: /dev/sdc
file format: qcow2
virtual size: 7.0G (7516192768 bytes)
disk size: 0
cluster_size: 65536
backing file: /dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-1 (actual path: /dev//dev/disk/by-path/ip-10.66.9.64:3260-iscsi-iqn.2001-04.com.example:storage.disk1.amiens.sys1.xyz-lun-1)

[root@shu ~]# qemu-img info /dev/sdd
image: /dev/sdd
file format: qcow2
virtual size: 7.0G (7516192768 bytes)
disk size: 0
cluster_size: 65536
Comment 1 Shaolong Hu 2012-05-04 06:13:35 EDT
test with "true"=false in step 3, the same error.
Comment 2 Paolo Bonzini 2012-05-04 11:26:18 EDT
I could not reproduce this one, but it seems similar enough to bug 818876.  Let's retest it with the same brew build.
Comment 3 Ademar Reis 2012-05-07 14:43:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation Needed
Comment 4 Shaolong Hu 2012-05-07 22:36:35 EDT
Patches in bug 818876 also fix this one.
https://bugzilla.redhat.com/show_bug.cgi?id=818876#c5
Comment 5 Ademar Reis 2012-05-08 10:26:49 EDT
(In reply to comment #4)
> Patches in bug 818876 also fix this one.
> https://bugzilla.redhat.com/show_bug.cgi?id=818876#c5

I'll close as duplicate to speed up the process (even though they're not the exact same use-case, they're very similar and share the same root cause).

*** This bug has been marked as a duplicate of bug 818876 ***

Note You need to log in before you can comment on or make changes to this bug.