Bug 818897 - Provisioning with file preservation fails due to bug in merge-rd.sh
Provisioning with file preservation fails due to bug in merge-rd.sh
Status: CLOSED DUPLICATE of bug 796466
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
541
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 06:08 EDT by dgurtner
Modified: 2012-05-04 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 13:48:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dgurtner 2012-05-04 06:08:43 EDT
Description of problem:

When trying to provision a RHEL 6.6.2 system from within the RHN Satellite web GUI, and using file preservatino in the kickstart profile used for the provisiong an error occurs:
D: Sending back response(2, 'Error creating the new RAM disk', {'status': 2, 'stderr': '\ngzip: /boot/initrd.img: not in gzip format\n/usr/sbin/merge-rd.sh: line 54: return: -1: invalid option\nreturn: usage: return [n]\n', 'stdout': ''})

This is due to the fact that the initrd.img in RHEL 6.6.2 isn't in gzip format anymore. The /usr/sbin/merge-rd.sh doesn't refelect this change to the initrd.img yet.

Version-Release number of selected component (if applicable):

spacewalk-koan-0.2.7-9.el6sat.noarch

How reproducible:

Always

Steps to Reproduce:
1. Creat a kickstart profile with a RHEL 6.6.2 Kickstart tree (i.e. ks-rhel-x86_64-server-6-6.2)
2. Enable file preservation for this kickstart profile
3. Provision a system with this kickstart profile
  
Actual results:

The provisioning fails with error:
Client execution returned "Error creating the new RAM disk" (code 2)

Expected results:

Successful provisioning of the system


Additional info:
I have an open customer case about this issue. Case Nr.00634224
Comment 1 Clifford Perry 2012-05-04 13:48:54 EDT
We are already tracking the fact that in RHEL 6.2 this format changed, breaking us. bug 796466 is currently ON_QA and should be out within the next weeks via an errata, in the RHN Tools channels.

Regards,
Cliff

*** This bug has been marked as a duplicate of bug 796466 ***

Note You need to log in before you can comment on or make changes to this bug.