Bug 818943 - Review Request: jtds - SQL Server and Sybase JDBC driver
Review Request: jtds - SQL Server and Sybase JDBC driver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Radej
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 848096
  Show dependency treegraph
 
Reported: 2012-05-04 09:04 EDT by gil cattaneo
Modified: 2012-09-18 01:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 20:58:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tradej: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description gil cattaneo 2012-05-04 09:04:35 EDT
Spec URL: <spec info here>
SRPM URL: <srpm info here>
Description: TDS is an open source 100% pure Java (type 4) JDBC 3.0 driver 
for Microsoft SQL Server (6.5, 7, 2000,2005, and 2008) and
Sybase (10, 11, 12, 15). jTDS is based on FreeTDS and is currently the
fastest production-ready JDBC  driver for SQL Server and Sybase.
jTDS is 100% JDBC 3.0 compatible, supporting forward-only and
scrollable/updateable ResultSets, concurrent (completely 
independent) Statements and implementing all the DatabaseMetaData and 
ResultSetMetaData methods.

tested on http://koji.fedoraproject.org/koji/taskinfo?taskID=4052676
Comment 1 Alexander Kurtakov 2012-05-04 09:19:54 EDT
No links to the spec and srpm!
Comment 2 gil cattaneo 2012-05-04 09:44:02 EDT
Spec URL: http://gil.fedorapeople.org/jtds.spec
SRPM URL: http://gil.fedorapeople.org/jtds-1.2.5-1.fc16.src.rpm
sorry
Comment 3 Tomas Radej 2012-07-17 09:25:12 EDT
Taking it.
Comment 4 Tomas Radej 2012-07-23 06:20:40 EDT
Package Review
==============

Key:
- = N/A
x = Pass
! = Fail
? = Not evaluated



==== Generic ====
[x]: EXTRA Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: EXTRA Spec file according to URL is the same as in SRPM.
[!]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[x]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Buildroot is not present
     Note: Unless packager wants to package for EPEL5 this is fine
[!]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: Clean would be needed if support for EPEL is required
[!]: MUST Sources contain only permissible code or content.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
     Note: Note: defattr macros not found. They would be needed for EPEL5
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[-]: MUST Package contains desktop file if it is a GUI application.
[-]: MUST Development files must be in a -devel package
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[!]: MUST Package complies to the Packaging Guidelines
[x]: MUST Spec file lacks Packager, Vendor, PreReq tags.
[x]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf would be needed if support for EPEL5 is required
[-]: MUST Large documentation files are in a -doc subpackage, if required.
[x]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[!]: MUST License field in the package spec file matches the actual license.
[x]: MUST License file installed when any subpackage combination is installed.
[x]: MUST Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: MUST Package is named using only allowed ascii characters.
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST Package does not generate any conflict.
     Note: Package contains no Conflicts: tag(s)
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Package is not relocatable.
[!]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[-]: MUST Package contains systemd file(s) if in need.
[x]: MUST File names are valid UTF-8.
[x]: SHOULD Reviewer should test that the package builds in mock.
[-]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: SHOULD Package functions as described.
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[x]: SHOULD Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: SHOULD SourceX / PatchY prefixed with %{name}.
[x]: SHOULD SourceX is a working URL.
[-]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[-]: SHOULD %check is present and all tests pass.
[x]: SHOULD Packages should try to preserve timestamps of original installed
     files.
[x]: SHOULD Spec use %global instead of %define.


==== Java ====
[x]: MUST If source tarball includes bundled jar/class files these need to be
     removed prior to building
[x]: MUST Packages have proper BuildRequires/Requires on jpackage-utils
[x]: MUST Fully versioned dependency in subpackages, if present.
[x]: MUST Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: MUST Javadoc subpackages have Requires: jpackage-utils
[x]: MUST Javadocs are placed in %{_javadocdir}/%{name} (no -%{version}
     symlink)
[x]: SHOULD Package has BuildArch: noarch (if possible)
[x]: SHOULD Package uses upstream build method (ant/maven/etc.)


==== Maven ====
[x]: MUST Pom files have correct add_maven_depmap call
     Note: Some add_maven_depmap calls found. Please check if they are correct
[x]: MUST Old add_to_maven_depmap macro is not being used
[x]: MUST Packages DOES NOT have Requires(post) and Requires(postun) on
     jpackage-utils for %update_maven_depmap macro
[x]: MUST If package contains pom.xml files install it (including depmaps)
     even when building with ant
[x]: MUST Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: MUST Packages use %{_mavenpomdir} instead of %{_datadir}/maven2/poms

Rpmlint
-------
Checking: jtds-1.2.5-1.fc16.src.rpm
          jtds-javadoc-1.2.5-1.fc16.noarch.rpm
          jtds-1.2.5-1.fc16.noarch.rpm
jtds.src: W: spelling-error %description -l en_US scrollable -> scroll able, scroll-able, Scrabble
jtds.src: W: spelling-error %description -l en_US updateable -> update able, update-able, update
jtds-javadoc.noarch: E: incorrect-fsf-address /usr/share/doc/jtds-javadoc-1.2.5/LICENSE
jtds.noarch: W: spelling-error %description -l en_US scrollable -> scroll able, scroll-able, Scrabble
jtds.noarch: W: spelling-error %description -l en_US updateable -> update able, update-able, update
jtds.noarch: E: incorrect-fsf-address /usr/share/doc/jtds-1.2.5/LICENSE
3 packages and 0 specfiles checked; 2 errors, 4 warnings.


Rpmlint (installed packages)
----------------------------
# rpmlint jtds
jtds.noarch: I: enchant-dictionary-not-found en_US
jtds.noarch: W: invalid-url URL: http://jtds.sourceforge.net/ HTTP Error 503: Service Unavailable
jtds.noarch: E: incorrect-fsf-address /usr/share/doc/jtds-1.2.5/LICENSE
1 packages and 0 specfiles checked; 1 errors, 1 warnings.
# echo 'rpmlint-done:'

Requires
--------
jtds-javadoc-1.2.5-1.fc16.noarch.rpm (rpmlib, GLIBC filtered):
    
    jpackage-utils  

jtds-1.2.5-1.fc16.noarch.rpm (rpmlib, GLIBC filtered):
    
    java  
    jcifs  
    jpackage-utils  

Provides
--------
jtds-javadoc-1.2.5-1.fc16.noarch.rpm:
    
    jtds-javadoc = 1.2.5-1.fc16

jtds-1.2.5-1.fc16.noarch.rpm:
    
    jtds = 1.2.5-1.fc16
    mvn(net.sourceforge.jtds:jtds)  

MD5-sum check
-------------
http://sourceforge.net/projects/jtds/files/jtds/1.2.5/jtds-1.2.5-src.zip :
  MD5SUM this package     : ec6ecc7c7af9c177e5f52d24faedca91
  MD5SUM upstream package : ec6ecc7c7af9c177e5f52d24faedca91


Generated by fedora-review 0.2.0 (53cc903) last change: 2012-07-09
Command line :/usr/bin/fedora-review -b 818943
External plugins:

ISSUES:
[!]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: MUST Package contains no bundled libraries.
[!]: MUST Sources contain only permissible code or content.
[!]: MUST Package complies to the Packaging Guidelines
>>>> In lib, there are binary files clearly from different projects. It is 
>>>> necessary to determine the license of each of them and remove those,
>>>> whose licensing terms prohibit redistribution without source
>>>> code. That means removing them prior to packaging, according to 
>>>> http://fedoraproject.org/wiki/Packaging:SourceURL#When_Upstream_uses_Prohibited_Code .
>>>> Also, there are some DLLs apparently for Windows machines.
>>>> If any of the aforementioned files is necessary and can not be built
>>>> from source (i. e. in a separate package), this package may not be
>>>> included in Fedora. 

[!]: MUST License field in the package spec file matches the actual license.
>>>> The project contains several files with a licence different from LGPL:
>>>> Namely:
>>>> main/net/sourceforge/jtds/util/MD5Digest.java: MIT/X11 (BSD like) 
>>>> main/net/sourceforge/jtds/util/GeneralDigest.java: MIT/X11 (BSD like) 
>>>> main/net/sourceforge/jtds/util/MD4Digest.java: MIT/X11 (BSD like) 
>>>> main/net/sourceforge/jtds/util/MD5Digest.java: MIT/X11 (BSD like) 
>>>> main/net/sourceforge/jtds/util/GeneralDigest.java: MIT/X11 (BSD like) 
>>>> main/net/sourceforge/jtds/util/MD4Digest.java: MIT/X11 (BSD like) 
>>>> Please, add this licence to the License field in spec

[!]: MUST Requires correct, justified where necessary.
>>>> Requires on zip is unnecessary, please, remove it

[!]: Rpmlint
>>>> The licence file has the old FSF address (see Rpmlint output), please
>>>> notify upstream about it.

*** NOT APPROVED ***
Comment 5 gil cattaneo 2012-07-23 07:14:09 EDT
Spec URL: http://gil.fedorapeople.org/jtds/1/jtds.spec
SRPM URL: http://gil.fedorapeople.org/jtds/1/jtds-1.2.5-1.fc16.src.rpm

- remvoved BR zip
- edit license field
- corrected FSF address
- repackaged SOURCE0 (removed bundled libraries and no permissible code or content)
Comment 6 Tomas Radej 2012-07-24 08:57:37 EDT
Thank you. 

1) You didn't really have to correct the FSF address, but please make sure upstream knows it. Keep the current state, though, it is fine.

2) License field is incorrect (BSD), the correct license is MIT.

Other than that, it seems good.
Comment 7 gil cattaneo 2012-08-10 03:36:33 EDT
Spec URL: http://gil.fedorapeople.org/jtds/2/jtds.spec
SRPM URL: http://gil.fedorapeople.org/jtds/2/jtds-1.2.5-3.fc16.src.rpm
- edit license field
- corrected FSF address
Comment 8 Tomas Radej 2012-08-21 11:10:52 EDT
Looks good now.

*** APPROVED ***
Comment 9 gil cattaneo 2012-08-21 11:37:13 EDT
New Package SCM Request
=======================
Package Name: jtds
Short Description: SQL Server and Sybase JDBC driver
Owners: gil
Branches: f17 f18
InitialCC: java-sig
Comment 10 Gwyn Ciesla 2012-08-21 11:55:13 EDT
Git done (by process-git-requests).
Comment 11 Fedora Update System 2012-08-21 12:58:00 EDT
jtds-1.2.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/jtds-1.2.6-1.fc17
Comment 12 Fedora Update System 2012-08-21 13:08:34 EDT
jtds-1.2.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/jtds-1.2.6-1.fc18
Comment 13 Fedora Update System 2012-08-22 10:38:18 EDT
jtds-1.2.6-1.fc18 has been pushed to the Fedora 18 testing repository.
Comment 14 Fedora Update System 2012-08-30 20:58:18 EDT
jtds-1.2.6-1.fc17 has been pushed to the Fedora 17 stable repository.
Comment 15 Fedora Update System 2012-09-17 19:44:15 EDT
jtds-1.2.6-1.fc18 has been pushed to the Fedora 18 stable repository.

Note You need to log in before you can comment on or make changes to this bug.