Bug 818990 - Update to OpenERP upstream status.
Update to OpenERP upstream status.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-trml2pdf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cristian Ciupitu
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 10:18 EDT by Alec Leamas
Modified: 2012-05-09 14:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-09 14:20:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from satchmo bundled version 1.2 to current OE version (76.74 KB, patch)
2012-05-04 10:18 EDT, Alec Leamas
no flags Details | Diff

  None (edit)
Description Alec Leamas 2012-05-04 10:18:31 EDT
Created attachment 582130 [details]
Patch from satchmo bundled version 1.2 to current OE version

trml2pdf is an old version, which is not usable from OpenERP. OTOH, the developer of trml2pdf is a OpenERP employee, and this code has been maintained over time this company. The overall diff is attached.

Looking at the satchmo project at https://bitbucket.org/chris1610/satchmo/ it's clear that trml2pdf is a bundled library in that context. The library does not seem to be actively maintained there, it's just listed as a requirement.

OTOH, trml2pdf is just a directory in the OE sources. OE does not maintain it as a separate project. But they do maintain it.

Given these facts I request that python-trml2pdf is updated to OE's current state, with the motivation that they represent the actual upstream for these sources.

No fedora package of today uses python-trml2pdf.
Comment 1 Alec Leamas 2012-05-04 11:56:45 EDT
I have applied for a bundling exception, heavily related to this bug: https://fedorahosted.org/fpc/ticket/171
Comment 2 Alec Leamas 2012-05-09 14:20:22 EDT
The FPC decision (link above)  is that this package should either be renamed or retired, and that openerp is requested to provide an python-trml2pdf package based on oe sources. Which make this bug obsolete. Closing.

Note You need to log in before you can comment on or make changes to this bug.