Bug 818998 - Support configurable refresh interval in new chart implementation
Support configurable refresh interval in new chart implementation
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity low
: ER07
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks: 872347
  Show dependency treegraph
 
Reported: 2012-05-04 10:47 EDT by Charles Crouch
Modified: 2015-02-01 18:28 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:34:14 EST
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker PRODMGT-148 Major Closed The Metric Chart should be redrawn automatically as was performed in JBoss ON 2.4 2014-03-14 09:01:25 EDT

  None (edit)
Description Charles Crouch 2012-05-04 10:47:16 EDT
This is being driven by the Feature request here: https://issues.jboss.org/browse/PRODMGT-148

As part of the new chart implementation in RHQ we should make sure we provide the ability for the user to refresh the chart (or set of charts, if we're displaying multiple related charts together) on a user selectable frequency, e.g. every 1, 5, 10mins say.

For obvious reasons, related to the gwt architecture, this won't be implemented in the same way as it was in JON2.4, via a whole page refresh.
Comment 3 Heiko W. Rupp 2013-09-18 15:40:10 EDT
commit b710b0bd19e646b453e2bf535cc2315213472300
Author: Mike Thompson <mithomps@redhat.com>
Date:   Tue Sep 10 13:17:55 2013 -0700

    [BZ 818998] Support configurable refresh interval in new chart implementation.
Comment 4 Mike Thompson 2013-09-24 11:16:40 EDT
Confirming this is done and checked into master.
Comment 5 Jeeva Kandasamy 2013-10-17 10:58:13 EDT
Refreshing every 1 min once even though I select 5 mins or 10  minutes. hence I'm moving this bug to assigned state.

If I refresh the complete page it is working as I configured on 'Refresh Interval'. If I change it I need to reload the complete again to make work it on selected interval.

Browser: Firefox ESR 17.0.7
JON Version:
JBoss Operations Network
Version: 3.2.0.ER3
Build Number: c0742ed:90dd474
GWT Version: 2.5.0
SmartGWT Version: 3.0
Comment 6 Mike Thompson 2013-11-11 11:01:12 EST
Looks like it is fixed at 1 min intervals regardless of the setting (e.g., 5 min).
Comment 7 Mike Thompson 2013-11-19 15:31:30 EST
Committed to master: 98e4b6a
Comment 8 Mike Thompson 2013-11-20 12:10:11 EST
Committed to release/jon3.2.x as: fc8729a
Time: 12:09 EST Nov 20, 2013.

Had to patch ButtonBardateTimeRangeEditor.java as it contained code from a previous commit that was in master but not in this release branch.
Comment 9 Simeon Pinder 2013-11-22 14:11:58 EST
Moving to ER07 target milestone and to ON_QA as this fix is in the ER7 brew build.
Comment 10 Sunil Kondkar 2013-11-28 08:41:35 EST
Verified on Version : 3.2.0.ER7 Build Number : e8e6401:ff0061d

Verified the refresh intervals are working:  No refresh, 1 minute, 5 minutes and 10 minutes in charts of individual resource/compatible groups on firefox and IE9.

Note You need to log in before you can comment on or make changes to this bug.