Bug 819068 - ipa-client-install caused a crash
ipa-client-install caused a crash
Status: CLOSED DUPLICATE of bug 817867
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-04 14:11 EDT by Namita Soman
Modified: 2012-05-18 10:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-18 10:06:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback (1.94 KB, text/plain)
2012-05-04 14:12 EDT, Namita Soman
no flags Details

  None (edit)
Description Namita Soman 2012-05-04 14:11:11 EDT
Description of problem:
While verifying bug 728543, the client install crashed. Cannot recreate it again. So cannot specify steps:

Attaching traceback, and after reboot, was able to reinstall successfully


Version-Release number of selected component (if applicable):
ipa-client-2.2.0-12.el6.x86_64

How reproducible:
happened only once

Steps to Reproduce:
1. on a machine with a different hostname, installed server :
ipa-server-install -p secret123 -a secret123 --hostname=ipa.testrelm.com
--no-host-dns
2. Created a host record
ipa host-add vm-138.example.com --password=foo --force
3. On client's /etc/hosts added server name and ip
3. Installed client:
ipa-client-install --server ipa.testrelm.com --domain testrelm.com --hostname hp-xw8600-01.testrelm.com -w foo
  
Actual results:
got a traceback. attaching email which includes the traceback

Expected results:
if install fails, roll back and leave machine in clean state
but really - should have installed successfuly. After reboot, using same command, was able to install successfully.

Additional info:
Comment 2 Namita Soman 2012-05-04 14:12:59 EDT
Created attachment 582180 [details]
traceback
Comment 3 Martin Kosek 2012-05-07 03:55:50 EDT
The traceback will be fixed when a patch for Bug 817867 is in. Since we cannot reproduce the issue itself (Decrypt integrity check failed), we may want to close this BZ.
Comment 4 Martin Kosek 2012-05-09 03:03:20 EDT
Namita, can you please try to reproduce the issue with the traceback ("Decrypt integrity check failed")? If you can longer reproduce it, I think we can close this as a duplicate of Bug 817867 as the traceback is fixed there.
Comment 5 RHEL Product and Program Management 2012-05-13 00:04:37 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.