Bug 81907 - GDM sets incorrect locale
GDM sets incorrect locale
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
phoebe
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Mike McLean
: Triaged
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-01-14 21:36 EST by Owen Taylor
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 18:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Owen Taylor 2003-01-14 21:36:52 EST
Choose American English (or any other language) from the install,
log in.

You get a GDM_LANG/LANG setting of, e.g., en_US.utf8. Xlib
requires en_US.UTF-8 to function correctly.

I'm not sure if this is a locale.alias problem or there is 
supposed to be a translation of utf8 to UTF-8 in the GDM
code. 

It worked correctly in 8.0
Comment 1 Havoc Pennington 2003-01-14 22:13:11 EST
The gdm locale.alias does have "UTF-8" so there is something strange going on.
(someday we really should just fix Xlib here...)
Comment 2 Havoc Pennington 2003-01-15 12:34:11 EST
via email:

I fixed it in CVS and it's in 2.4.1.1 so perhaps you're looking at the
"fixed" version :)
                                                                               
         
George
Comment 3 Owen Taylor 2003-01-16 16:14:34 EST
Taking GDM target/blockers.
Comment 4 Owen Taylor 2003-01-16 19:22:30 EST
Indeed seems to be fixed 2.4.1.1

Note You need to log in before you can comment on or make changes to this bug.