Bug 819137 - lscgroup drops first character of path unless prefixed with slash
Summary: lscgroup drops first character of path unless prefixed with slash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Mike Gahagan
URL:
Whiteboard:
Depends On:
Blocks: 782183 787802 819568 819574 840683
TreeView+ depends on / blocked
 
Reported: 2012-05-05 02:38 UTC by Travis Gummels
Modified: 2018-11-30 22:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: lscgroup drops first character of path unless prefixed with slash Consequence: possibility to generate invalid path Fix: do not drop first character of path Result: lscgroup doesn't drop first character of path if path is not prefixed with slash
Clone Of:
: 819568 819574 (view as bug list)
Environment:
Last Closed: 2013-02-21 10:47:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to underlying problem (1.26 KB, patch)
2012-05-14 17:44 UTC, Ben Woodard
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0452 normal SHIPPED_LIVE libcgroup bug fix and enhancement update 2013-02-20 20:47:36 UTC

Description Travis Gummels 2012-05-05 02:38:31 UTC
Description of problem:

lscgroup ltrims path unless prefixed with slash.

$ lscgroup freezer:/libvirt
freezer:/libvirt/
freezer:/libvirt/lxc
freezer:/libvirt/qemu

$ lscgroup freezer:libvirt
freezer:/ibvirt/
freezer:/ibvirt/lxc
freezer:/ibvirt/qemu

Version-Release number of selected component (if applicable):

libcgroup-0.37-3.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
See above.
  
Actual results:
first character of path dropped

Expected results:
path kept intact

Additional info:
LLNL requests this BZ made public.

Comment 2 Ivana Varekova 2012-05-10 07:14:28 UTC
Fixed in upstream: https://sourceforge.net/mailarchive/message.php?msg_id=29243208

Comment 3 Ben Woodard 2012-05-14 17:44:26 UTC
Created attachment 584420 [details]
patch to underlying problem

Ivana, there is a deeper underlying problem and a harmless bug.

If you look at this attached patch you will see that in many cases there is a double "/" in the path it is constructing in the api.c so it ends up with a "//" in the middle of the path that it is going to look in. This appears to be a bug that was worked around with the +1 over in lsgroup.c So removing the addition of the 2nd "/" makes everything work correctly and the workaround is not needed.

Also while debugging this, I discovered another harmless cut/paste bug.

Comment 4 Ivana Varekova 2012-06-30 08:34:29 UTC
Thanks,
now upstream patch changes api function not to add "/" character when it is not needed and lscgroup does not remove "/" itself
(http://sourceforge.net/mailarchive/forum.php?thread_name=From_varekova%40users.sourceforge.net_Fri_Jun_22_19%3A18%3A35_2012&forum_name=libcg-commits)

Comment 8 Mike Gahagan 2012-12-19 20:08:55 UTC
Confirmed fix for this bug is in libcgroup-0.37-6

[root@dhcp137-133 tmp]# lscgroup memory:load-tasks
memory:/oad-tasks/
[root@dhcp137-133 tmp]# lscgroup memory:/load-tasks
memory:/load-tasks/
[root@dhcp137-133 tmp]# rpm -q libcgroup
libcgroup-0.37-3.el6.x86_64

rpm -Fvh http://10.13.137.43/repos/libcgroup/libcgroup-0.37-6.el6.x86_64.rpm                          
Retrieving http://10.13.137.43/repos/libcgroup/libcgroup-0.37-6.el6.x86_64.rpm                        
[root@dhcp137-133 tests]# rpm -q libcgroup                                                            
libcgroup-0.37-6.el6.x86_64
[root@dhcp137-133 tmp]# lscgroup memory:load-tasks
memory:/load-tasks/                               
[root@dhcp137-133 tmp]# lscgroup memory:/load-tasks
memory:/load-tasks/

Comment 10 errata-xmlrpc 2013-02-21 10:47:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0452.html


Note You need to log in before you can comment on or make changes to this bug.