Bug 819138 - repoclosure failure on 17.TC5 DVDs (eclipse)
repoclosure failure on 17.TC5 DVDs (eclipse)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-05-04 22:48 EDT by Andre Robatino
Modified: 2012-05-16 02:05 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-16 02:05:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-05-04 22:48:29 EDT
Description of problem:
17.TC3 i386 DVD:

package: 1:eclipse-jdt-4.2.0-0.17.I201204171000.fc17.i686 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0

17.TC3 x86_64 DVD:

package: 1:eclipse-jdt-4.2.0-0.17.I201204171000.fc17.x86_64 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0
Comment 1 Alexander Kurtakov 2012-05-07 02:33:39 EDT
java-1.7.0-openjdk-javadoc has the following provide:
java-javadoc = 1:1.7.0.3-2.1.fc17.6

Check here http://koji.fedoraproject.org/koji/rpminfo?rpmID=3096069 . I don't see a reason for not being resolved unless the package is blocked from the DVD for some reason.
Comment 2 Alexander Kurtakov 2012-05-07 02:46:31 EDT
Can we get java-1.7.0-openjdk-javadoc unblocked? It is part of the JDK when taken from http://www.oracle.com/technetwork/java/javase/downloads/index.html so it is good to have the exactly same experience this would also fix the eclipse-jdt issue as this is critical integration because of the number of classes/methods in the JDK.
Comment 3 Adam Williamson 2012-05-07 11:32:55 EDT
Discussed at 2012-05-07 QA meeting, acting as a blocker review meeting. Accepted as a blocker per criterion "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Dennis Gilmore 2012-05-07 20:53:28 EDT
the kickstart for the install dvd has
-*javadoc*

making sure that all javadoc packages are excluded. its done in a section with a general comment of being in size. ill try adding java-1.7.0-openjdk-javadoc after the - and that should pull it in.
Comment 5 Adam Williamson 2012-05-08 02:36:28 EDT
I rather suspect all this Eclipse / Java-related excitement is caused by:

http://git.fedorahosted.org/git/?p=comps.git;a=commitdiff;h=8b40d37d1b3101b6684a62ceec3bb5c856404b07

"Add eclipse-mylyn-fedora-integration to eclipse."

Can we just kick that out on the grounds it's causing trouble and is late? Or should we try and fix all this mess up?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-05-08 02:57:56 EDT
akurtakov says this is more likely to be caused by:

http://pkgs.fedoraproject.org/gitweb/?p=eclipse.git;a=commit;h=7204f12da6e1914f81f95a0f4d7919ea774ccc73

and so dropping mylyn wouldn't fix it. Doing what dgilmore suggests in comment #4 should fix it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Andre Robatino 2012-05-10 01:14:49 EDT
Problem still exists on 17.TC4 DVDs.

17.TC4 i386 DVD:

package: 1:eclipse-jdt-4.2.0-0.20.I201205031800.fc17.i686 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0

17.TC4 x86_64 DVD:

package: 1:eclipse-jdt-4.2.0-0.20.I201205031800.fc17.x86_64 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0
Comment 8 Adam Williamson 2012-05-10 01:29:38 EDT
Yes. dgilmore tried his fix from c#4 but it seems not to have worked. He's going to try and figure out why tomorrow.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Andre Robatino 2012-05-12 03:51:41 EDT
Problem still exists on 17.TC5 DVDs.

17.TC5 i386 DVD:

package: 1:eclipse-jdt-4.2.0-0.20.I201205031800.fc17.i686 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0

17.TC5 x86_64 DVD:

package: 1:eclipse-jdt-4.2.0-0.20.I201205031800.fc17.x86_64 from myrepo
  unresolved deps: 
     java-javadoc >= 1:1.7.0
Comment 10 Alexander Kurtakov 2012-05-12 04:35:24 EDT
Well, someone needs to unblock java-1.7.0-openjdk-javadoc. I have no idea why but the java-1.6.0-openjdk-javadoc was on the medium somehow prior to switching to 1.7.
Comment 11 Bruno Wolff III 2012-05-13 11:58:52 EDT
This commit explains the difference between how things worked in f16 vs f17:
commit 9d7f82d91a6db224e802939b4df595b43521afb7
Author: Daniel Mach <dmach@redhat.com>
Date:   Mon Mar 5 06:10:17 2012 -0500

    Handle excludes during depsolving.
    
    Prefiously, packages were excluded from the initial package list,
    but could have been pulled in during depsolving. This patch excludes
    selected packages for good. Supported syntax is -$name or -%name.%arch
    including wildchars.

Arguably this change is a good thing as you no longer have to use odd repo commands to really keep stuff out. However for javadoc it's going to be a pain to exclude everything but java-javadoc-1.7.
Comment 12 Bruno Wolff III 2012-05-13 14:03:55 EDT
So you might be able to do this using something like
-[-_0-9a-ik-z]*javadoc*
-j[-_0-9b-z]*javadoc*
-ja[-_0-9a-uw-z]*javadoc*
-jav[-_0-9b-z]*javadoc*
-java[_0-9a-z]*javadoc*
-java-[-_02-9a-z]*javadoc*

That would just leave java-1.5.0-gcj-javadoc and java-1.7.0-openjdk-javadoc from *javadoc* and java-1.5.0-gcj-javadoc is already specifically excluded in the repo definitions.

I haven't tested this (with pungi) but it looks like normal file globing is supposed to be supported with should include bracketed ranges.
Comment 13 Andre Robatino 2012-05-16 02:05:16 EDT
Fixed in 17.TC6. No repoclosure problems.

Note You need to log in before you can comment on or make changes to this bug.