Bug 819149 - [abrt] system-config-firewall-1.2.29-4.fc16: fw_gui.py:76:destroy:RuntimeError: called outside of a mainloop
[abrt] system-config-firewall-1.2.29-4.fc16: fw_gui.py:76:destroy:RuntimeErro...
Status: CLOSED DUPLICATE of bug 876013
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:849e2e174b8e599ecf63ee6caa0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-05 01:35 EDT by corjuela
Modified: 2012-11-13 03:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 03:26:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description corjuela 2012-05-05 01:35:54 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/system-config-firewall
comment:        I was configuring thw dynamic firewall but i can't close/hide the firewall configuration interface, when I try to restore the window (the middle option on the top right corner) the bug appear
executable:     /usr/bin/system-config-firewall
kernel:         3.3.2-6.fc16.x86_64
reason:         fw_gui.py:76:destroy:RuntimeError: called outside of a mainloop
time:           Sat 05 May 2012 12:24:14 AM COT
uid:            1000

backtrace:
:fw_gui.py:76:destroy:RuntimeError: called outside of a mainloop
:
:Traceback (most recent call last):
:  File "/usr/share/system-config-firewall/fw_gui.py", line 1590, in quit
:    self.destroy(args)
:  File "/usr/share/system-config-firewall/fw_gui.py", line 76, in destroy
:    gtk.main_quit()
:RuntimeError: called outside of a mainloop
:
:Local variables in innermost frame:
:self: <fw_gui.ui instance at 0x27611b8>
:args: (<gtk.Window object at 0x282c730 (GtkWindow at 0x2924180)>, <gtk.gdk.Event at 0x27cbcd8: GDK_DELETE>)

smolt_data:
:
:
:General
:=================================
:UUID: 4a0a5c12-d78d-4e10-be3f-21e8f8d29fb8
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4388.96
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T6600  @ 2.20GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2200
:System Memory: 3920
:System Swap: 1427
:Vendor: Dell Inc.
:System: Studio 1555 A13
:Form factor: Portable
:Kernel: 3.3.2-6.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(5348:5784:4136:702) pci, tg3, ETHERNET, NetLink BCM5784M Gigabit Ethernet PCIe
:(32902:10816:4136:702) pci, None, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10817:4136:702) pci, pcieport, PCI/PCI, Mobile 4 Series Chipset PCI Express Graphics Port
:(5348:17195:4136:13) pci, wl, NETWORK, Wireless 1510 Wireless-N WLAN Mini-Card
:(32902:10544:4136:702) pci, None, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4136:702) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:4136:702) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10549:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4136:702) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:4136:702) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(4480:2130:4136:702) pci, r852, BASE, xD-Picture Card Controller
:(32902:10566:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(4480:2098:4136:702) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:4136:702) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(4480:1426:4136:702) pci, r592, BASE, R5C592 Memory Stick Bus Host Adapter
:(32902:10558:4136:702) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4136:702) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43576:4136:702) pci, snd_hda_intel, MULTIMEDIA, RV710/730
:(4098:38227:4136:702) pci, radeon, VIDEO, M92 [Mobility Radeon HD 4500/5100 Series]
:(32902:10570:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda7 / ext4 4096 4096 7072103 5535061 5464275 1777664 1615874 1615874
:/dev/sda8 /home ext4 4096 4096 18422832 2012494 1089820 4620288 4602888 4602888
:/dev/sda5 WITHHELD fuseblk 4096 4096 13123070 8053172 8053172 32245456 32231394 32231394
:
Comment 1 Jiri Popelka 2012-11-13 03:26:16 EST

*** This bug has been marked as a duplicate of bug 876013 ***

Note You need to log in before you can comment on or make changes to this bug.