Bug 819151 - at the end of any 32-bit TC3 install, "There was an error installing the bootloader. The system may not be bootable."
at the end of any 32-bit TC3 install, "There was an error installing the boot...
Status: CLOSED DUPLICATE of bug 818378
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
Reported: 2012-05-05 02:31 EDT by Andre Robatino
Modified: 2012-05-06 14:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-05 19:49:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-05-05 02:31:54 EDT
Description of problem:
At the end of a minimal non-networked install from the 17.TC3 i386 DVD, I get the message "There was an error installing the bootloader. The system may not be bootable." and indeed it isn't. Upon booting, there is nothing but a blinking cursor. The same thing happens with an i386 text install. It does NOT happen on x86_64. I haven't tried a netinstall. Please reassign to the correct component.

P.S. Rescue mode allows me to see the installed system, at least.

Version-Release number of selected component (if applicable):
17.TC3 i386 DVD

How reproducible:
Comment 1 Andre Robatino 2012-05-05 09:26:48 EDT
Checked that the same error happens at the end of any 32-bit TC3 install (networked or non-networked, minimal or default package set, Install or Live). The error never happens on 64-bit.
Comment 2 Dennis Gilmore 2012-05-05 11:14:38 EDT
i imagine its one of two things, a grub2 bug or anaconda incorrectly calling grubs installation. ill reassign to grub2 for further investigation.
Comment 3 Kevin Fenzi 2012-05-05 13:26:25 EDT
Might be informative to get the output (if any) from the alt-f3 / alt-f4 vty's after seeing the above error from installing the bootloader.
Comment 4 A.J. Werkman 2012-05-05 13:44:13 EDT
I see the same with a network install with the kernel booted from a USB-drive.

The last 10 line of program.log show:

21:14:07,461 INFO program: Running... /usr/sbin/lokkit --quiet --nostart -f --service=ssh
21:14:07,597 INFO program: Running... grub2-set-default Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE
21:14:07,833 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
21:14:09,143 ERR program: Generating grub.cfg ...
21:14:09,369 ERR program: Found linux image: /boot/vmlinuz-3.3.4-3.fc17.i686.PAE
21:14:09,387 ERR program: Found initrd image: /boot/initramfs-3.3.4-3.fc17.i686.PAE.img
21:14:09,543 ERR program: Warning: Please don't use old title `Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE' for GRUB_DEFAULT, use `Advanced options for Fedora Linux>Fedora Linux, with Linux 3.3.4-3.fc17.i686.PAE' (for versions before 2.00) or `gnulinux-advanced-a7a420c7-2bbb-499a-95a6-ff8786668d35>gnulinux-3.3.4-3.fc17.i686.PAE-advanced-a7a420c7-2bbb-499a-95a6-ff8786668d35' (for 2.00 or later)
21:14:10,723 ERR program: done
21:14:11,188 INFO program: Running... grub2-install --no-floppy /dev/sda
21:14:11,228 INFO program: source_dir doesn't exist. Please specify --target or --directory
Comment 5 Mads Kiilerich 2012-05-05 19:34:08 EDT
(In reply to comment #0)

Can someone confirm the scope of this bug? Does it affect _all_ 32 bit TC3 installations everywhere, or only some installations - for example related to specific hardware or specific installation options?

Robatino: Please provide more information - for example your anaconda logs.

(In reply to comment #4)
> 21:14:07,833 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
> 21:14:11,188 INFO program: Running... grub2-install --no-floppy /dev/sda

anaconda should run grub2-install before grub2-mkconfig ... but it will probably not make a big difference in most cases.

> 21:14:11,228 INFO program: source_dir doesn't exist. Please specify --target or
> --directory

That might be a duplicate of Bug 818378 "grub2 can't install because /proc/device-tree exists" ... but we don't know what problem Robatino saw and if it is related.
Comment 6 Andre Robatino 2012-05-05 19:43:55 EDT
It affects every 32-bit TC3 test install I did in either VirtualBox or KVM, as indicated in comment 1. The quickest way to reproduce it is a minimal 32-bit install (either networked or non-networked). I used all defaults, none of these were custom installs. I highly doubt this is hardware-specific.

I believe I saw the same error as in comment 4 when I tried using rescue mode and running "grub2-install /dev/sda" to fix the bootloader.
Comment 7 Mads Kiilerich 2012-05-05 19:49:57 EDT

*** This bug has been marked as a duplicate of bug 818378 ***
Comment 8 Andre Robatino 2012-05-05 19:51:46 EDT
BTW, bug 818378 was first reported with a 17 Beta install, but I never saw this on any compose before 17 Final TC3.
Comment 9 satellit 2012-05-06 14:03:18 EDT
just occurred on virtuabox install of fedora 17-tc3-i386-dvd

Note You need to log in before you can comment on or make changes to this bug.