Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 819236 - dcmtk-3.6.0-10 FTBFS
Summary: dcmtk-3.6.0-10 FTBFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dcmtk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mario Ceresa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F17FTBFS
TreeView+ depends on / blocked
 
Reported: 2012-05-05 20:44 UTC by Tom Lane
Modified: 2013-07-03 03:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-01 18:29:36 UTC
Type: Bug


Attachments (Terms of Use)
stripped-down patch (37.61 KB, patch)
2012-07-26 01:44 UTC, Tom Lane
no flags Details | Diff

Description Tom Lane 2012-05-05 20:44:15 UTC
Description of problem:
Current sources fail to build, with a bunch of errors like this:

In file included from /builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/libsrc/dimoimg.cc:36:0:
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h: In instantiation of 'DiMonoInputPixelTemplate<T1, T2, T3>::DiMonoInputPixelTemplate(DiInputPixel*, DiMonoModality*) [with T1 = unsigned char;\
 T2 = unsigned int; T3 = unsigned char]':
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/libsrc/dimoimg.cc:758:99:   required from here
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:79:17: error: 'determineMinMax' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of in\
stantiation [-fpermissive]
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:79:17: note: declarations in dependent base 'DiMonoPixelTemplate<unsigned char>' are not found by unqualified lookup
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:79:17: note: use 'this->determineMinMax' instead
In file included from /builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/libsrc/dimoimg.cc:36:0:
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:82:17: error: 'determineMinMax' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of in\
stantiation [-fpermissive]
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:82:17: note: declarations in dependent base 'DiMonoPixelTemplate<unsigned char>' are not found by unqualified lookup
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h:82:17: note: use 'this->determineMinMax' instead
In file included from /builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/libsrc/dimoimg.cc:36:0:
/builddir/build/BUILD/dcmtk-3.6.0/dcmimgle/include/dcmtk/dcmimgle/dimoipxt.h: In instantiation of 'DiMonoInputPixelTemplate<T1, T2, T3>::DiMonoInputPixelTemplate(DiInputPixel*, DiMonoModality*) [with T1 = unsigned char;\
 T2 = unsigned int; T3 = char]':

Version-Release number of selected component (if applicable):
dcmtk-3.6.0-10.fc18

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild

Additional info:
Possibly caused by a recent gcc upgrade.  According to the koji logs,
http://koji.fedoraproject.org/koji/packageinfo?packageID=11881
it's been failing since mid-January.

Comment 1 Mario Ceresa 2012-05-22 07:14:58 UTC
Thanks Tom for the report, I'll look into it

Mario

Comment 2 Jörg Riesmeier 2012-06-22 09:21:23 UTC
I guess this issue disappears after the following patch has been applied: http://git.dcmtk.org/web?p=dcmtk.git;a=patch;h=dbadc0d8f3760f65504406c8b2cb8633f868a258

Jörg (DCMTK developer/maintainer)

Comment 3 Tom Lane 2012-07-26 01:44:46 UTC
Created attachment 600422 [details]
stripped-down patch

The patch linked in comment #2 does not apply cleanly to dcmtk 3.6.0 --- it touches some files that don't exist in that tarball.  However, if you just remove those hunks, it applies and the result does build.  I attach a tested version of that patch.  (Mind you, I've only tested that it builds in rawhide mock.  I have no idea about testing dcmtk's functionality.)

I'd appreciate it if you could get dcmtk rebuilt as soon as practical.  I'd like to dump libtiff-compat from rawhide before the F18 branch, and this package is one of its few remaining dependencies.

Comment 4 Jörg Riesmeier 2012-07-26 09:57:48 UTC
Right, the above referenced patch applies to the development version of the DCMTK and not to the official release 3.6.0. It's simply a link to the git web interface of the public DCMTK. However, simply ignoring the patch of the file "ofstd/libsrc/ofchrenc.cc", which has been introduced _after_ the release, should do.

Comment 5 Gwyn Ciesla 2012-08-01 18:29:36 UTC
Committed and built in rawhide.


Note You need to log in before you can comment on or make changes to this bug.