Bug 819238 - [abrt] firefox-12.0-1.fc16: Process /usr/lib/firefox/firefox was killed by signal 11 (SIGSEGV)
[abrt] firefox-12.0-1.fc16: Process /usr/lib/firefox/firefox was killed by si...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
abrt_hash:a445103ee088cf0d3a1212eea45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-05 16:57 EDT by Mads Kiilerich
Modified: 2012-05-26 19:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 03:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (12.30 KB, text/plain)
2012-05-05 16:57 EDT, Mads Kiilerich
no flags Details
File: maps (35.70 KB, text/plain)
2012-05-05 16:57 EDT, Mads Kiilerich
no flags Details
File: backtrace (111.65 KB, text/plain)
2012-05-05 16:57 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2012-05-05 16:57:36 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib/firefox/firefox
comment:        Firefor regularly crashes after logging out from fronter.com/metropol . The automatic crash reporter pops up but I don't know where it report it and if there is any follow up on it.
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib/firefox/firefox
kernel:         3.3.4-1.fc16.i686
pid:            2460
pwd:            /home/maria
reason:         Process /usr/lib/firefox/firefox was killed by signal 11 (SIGSEGV)
time:           lør 05 maj 2012 22:42:31 CEST
uid:            500
username:       maria
xsession_errors: 

backtrace:      Text file, 114332 bytes
dso_list:       Text file, 12599 bytes
maps:           Text file, 36555 bytes

environ:
:XDG_VTNR=1
:XSUNTRANSPORT=shmem
:XDG_SESSION_ID=2
:HOSTNAME=baby
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=2460
:GPG_AGENT_INFO=/tmp/keyring-zoqDdW/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=gnome-shell-1403-baby-firefox-5_TIME2094886
:HISTSIZE=1000
:XDG_SESSION_COOKIE=0811fb99261739b5ec2bc5b400000014-1336248458.71319-2098027738
:GJS_DEBUG_OUTPUT=stderr
:GNOME_KEYRING_CONTROL=/tmp/keyring-zoqDdW
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:MOZILLA_FIVE_HOME=/usr/lib/firefox
:IMSETTINGS_MODULE=none
:USER=maria
:LD_LIBRARY_PATH=/usr/lib/firefox:/usr/lib/firefox/plugins:/usr/lib/firefox
:SSH_AUTH_SOCK=/tmp/keyring-zoqDdW/ssh
:GNOME_DISABLE_CRASH_DIALOG=1
:LIBPATH=/usr/lib/firefox:/usr/lib/firefox
:USERNAME=maria
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1173,unix/unix:/tmp/.ICE-unix/1173
:MOZ_APP_LAUNCHER=/usr/bin/firefox
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/mozilla-firefox.desktop
:MOZ_PLUGIN_PATH=/usr/lib/mozilla/plugins-wrapped:/usr/lib/firefox/plugins-wrapped
:MAIL=/var/spool/mail/maria
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/maria/bin
:DESKTOP_SESSION=gnome
:FONTCONFIG_PATH=/etc/fonts:/usr/lib/firefox/res/Xft
:QT_IM_MODULE=xim
:PWD=/home/maria
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1166
:LANG=da_DK.utf8
:GDM_LANG=da_DK.utf8
:XSUNSMESIZE=512
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/maria
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:DYLD_LIBRARY_PATH=/usr/lib/firefox:/usr/lib/firefox
:LOGNAME=maria
:MOZ_GRE_CONF=/etc/gre.d/gre.conf
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Dmcs1hv3ga,guid=5434d93f29b55a7e2c3112cb00000034
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SHLIB_PATH=/usr/lib/firefox:/usr/lib/firefox
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/maria
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-maria-0ietLO/database

smolt_data:
:
:
:Generelt
:=================================
:UUID: 284cc78f-71a3-483a-aa77-d3347317bd8b
:OS: Fedora release 16 (Verne)
:Standard kørselsniveau: Unknown
:Sprog: da_DK.utf8
:Platform: i686
:BogoMIPS: 3325.19
:Processorproducent: GenuineIntel
:Processormodel: Intel(R) Atom(TM) CPU N455   @ 1.66GHz
:Processormodelserie: 10
:Processorfamilie: 6
:Processormodelnummer: 28
:Antal af processorer: 2
:Processorhastighed: 1667
:Systemhukommelse: 993
:Systemswap: 2015
:Producent: Dell Inc.
:System: Inspiron 1018 A02
:Formfaktor: Portable
:Kerne: 3.3.4-1.fc16.i686
:SELinux aktiveret: 1
:SELinux regelsæt: targeted
:SELinux fremtvunget: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Enheder
:=================================
:(32902:10172:4136:1166) pci, None, PCI/ISA, NM10 Family LPC Controller
:(32902:40977:4136:1166) pci, i915, VIDEO, N10 Family Integrated Graphics Controller
:(32902:40978:4136:1166) pci, None, VIDEO, N10 Family Integrated Graphics Controller
:(32902:10192:4136:1166) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10194:4136:1166) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 2
:(32902:10200:4136:1166) pci, snd_hda_intel, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10202:4136:1166) pci, i801_smbus, SERIAL, N10/ICH 7 Family SMBus Controller
:(32902:9288:4136:1166) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(4332:33078:4136:1166) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10177:4136:1166) pci, ahci, STORAGE, N10/ICH7 Family SATA AHCI Controller
:(32902:10185:4136:1166) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4136:1166) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:40976:4136:1166) pci, agpgart-intel, HOST/PCI, N10 Family DMI Bridge
:(32902:10186:4136:1166) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10187:4136:1166) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4136:1166) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(4332:33142:4136:37272) pci, rtl8192ce, NETWORK, RTL8188CE 802.11b/g/n WiFi Adapter
:
:
:Information om filsystem
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_baby-lv_root / ext4 4096 4096 13092026 12014892 11883873 3276800 3158216 3158216
:/dev/mapper/vg_baby-lv_home /home ext4 4096 4096 15839637 15412723 14619328 3973120 3972126 3972126
:/dev/sda5 /boot ext4 1024 1024 508745 410892 385292 128016 127768 127768
:

var_log_messages:
:May  1 21:12:02 baby yum[4914]: Updated: firefox-12.0-1.fc16.i686
:May  5 22:42:36 baby abrt[2571]: Saved core dump of pid 2460 (/usr/lib/firefox/firefox) to /var/spool/abrt/ccpp-2012-05-05-22:42:31-2460 (294694912 bytes)
Comment 1 Mads Kiilerich 2012-05-05 16:57:41 EDT
Created attachment 582326 [details]
File: dso_list
Comment 2 Mads Kiilerich 2012-05-05 16:57:44 EDT
Created attachment 582327 [details]
File: maps
Comment 3 Mads Kiilerich 2012-05-05 16:57:48 EDT
Created attachment 582328 [details]
File: backtrace
Comment 4 Mads Kiilerich 2012-05-05 19:57:13 EDT
I don't see this on a bigger Dell with the same software versions.

I wonder if this could be related to running on an Atom cpu in combination with Fedora's optimization flags.
Comment 5 Martin Stransky 2012-05-07 03:27:56 EDT
mozalloc_handle_oom() - It looks like the box it running out of memory.
Comment 6 Mads Kiilerich 2012-05-26 16:25:02 EDT
It is a little machine with only 1 GB memory, but normal operation and running firefox works just fine and there is plenty of free swap space. It is only the logout from that page that consistently fails. It seems strange that it should need so much memory for that. That would look like a bug to me.

Running firefox with strace shows that it terminates after:

4055  mmap2(0xf0dea000, 4096, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xad1ff000
4055  madvise(0xf0dea000, 4096, MADV_NORMAL) = -1 ENOMEM (Cannot allocate memory)
4055  munmap(0xad1ff000, 4096)          = 0
4055  uname({sys="Linux", node="baby", ...}) = 0
4055  mmap2(0xf0dea000, 4096, PROT_NONE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xad1ff000
4055  madvise(0xf0dea000, 4096, MADV_NORMAL) = -1 ENOMEM (Cannot allocate memory)
4055  munmap(0xad1ff000, 4096)          = 0
4055  uname({sys="Linux", node="baby", ...}) = 0

I wonder if it could be trying to do some fancy memory operation that only works on PAE kernels.
Comment 7 Mads Kiilerich 2012-05-26 19:48:51 EDT
The problematic site use some invisible java. After removing icedtea-web the site complained about missing functionality but did apparently no longer crash. It seems like removing ~/.icedtea made the problem go away.

Note You need to log in before you can comment on or make changes to this bug.