Bug 819254 - kde-settings-kdm conflicts with gdm
kde-settings-kdm conflicts with gdm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 826910 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-05-05 21:30 EDT by Bruno Wolff III
Modified: 2012-06-13 14:27 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 14:27:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2012-05-05 21:30:12 EDT
Description of problem:

Version-Release number of selected component (if applicable):

Transaction Check Error:
  file /var/spool/gdm from install of kde-settings-kdm-4.8-8.fc18.noarch conflicts with file from package gdm-1:3.4.1-1.fc18.i686
  file /etc/ggz.modules.d from install of kdegames-6:4.8.3-1.fc18.i686 conflicts with file from package ggz-base-libs-0.99.5-10.fc17.i686
Comment 1 Kevin Kofler 2012-05-06 05:14:13 EDT
These are co-owned directories, not files.
Comment 2 Bruno Wolff III 2012-05-06 08:39:22 EDT
That output is the result of a yum error that blocks any updates scheduled for
that transaction. The conflict needs to be resolved (maybe there are permission
differences or something similar) or the packages need a conflicts declaration
so that yum can remove a package from the transaction (so that --skip-broken
will work) before the transaction test step.
Comment 3 Bruno Wolff III 2012-05-06 08:59:04 EDT
I have confirmed that the access protections for the two definitions of the directory are different. I saw some place on the lists that rpm has started caring about this in rawhide, so the issue may not have triggered a conflict in earlier releases.
Comment 4 Bruno Wolff III 2012-05-06 09:01:54 EDT
[root@bruno Packages]# rpm -qlvp k/kde-settings-kdm-4.8-8.fc18.noarch.rpm g/gdm-3.4.1-1.fc18.i686.rpm | grep spool
drwxrwxr-x    2 root    root                        0 Apr 30 12:04 /var/spool/gdm
drwxr-xr-x    2 root    root                        0 Apr 16 18:21 /var/spool/gdm
Comment 5 Kevin Kofler 2012-05-06 12:18:52 EDT
Oh duh, strange permissions…

gdm is the one having strange permissions here and should be fixed.
Comment 6 Ray Strode [halfline] 2012-05-08 10:50:08 EDT
We should probably just drop it.  Neither of us use it anymore, right?
Comment 7 Rex Dieter 2012-05-08 11:11:39 EDT
The code still supports looking there, but if plymouth doesn't use it, then dropping it indeed is the way to go.
Comment 8 Ray Strode [halfline] 2012-05-08 11:17:35 EDT
well plymouth still writes the file, but I'm thinking we could drop that now.
Comment 9 Kevin Kofler 2012-05-31 08:57:13 EDT
*** Bug 826910 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2012-06-12 19:11:01 EDT
Both kde-settings-kdm and gdm are on the F17 DVD, so it's a reasonable assumption they will be on the F18 Alpha DVD. Non-explicit conflicts like this are verboten, so proposing as an Alpha blocker:

"There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install"
Comment 11 Rex Dieter 2012-06-13 13:39:56 EDT
Dropped owning that dir in kde-settings:

%changelog
* Wed Jun 13 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8-15.1
- kde-settings-kdm conflicts with gdm (#819254)
Comment 12 Ray Strode [halfline] 2012-06-13 14:27:29 EDT
Dropped it in GDM as well.

Note You need to log in before you can comment on or make changes to this bug.