Bug 819255 - Installation of bootloader fails in a virtual machine
Installation of bootloader fails in a virtual machine
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-05 21:34 EDT by Mukundan Ragavan
Modified: 2012-07-18 13:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 13:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A screenshot showing the message stated in the bug report. (31.68 KB, image/png)
2012-05-05 21:34 EDT, Mukundan Ragavan
no flags Details
anaconda.log (13.13 KB, text/x-log)
2012-05-07 09:54 EDT, Mukundan Ragavan
no flags Details
program.log (84.83 KB, text/x-log)
2012-05-07 09:55 EDT, Mukundan Ragavan
no flags Details

  None (edit)
Description Mukundan Ragavan 2012-05-05 21:34:02 EDT
Created attachment 582353 [details]
A screenshot showing the message stated in the bug report.

Description of problem:
Installation of bootloader fails when trying to install using F17 TC3 live CD to a Virtual machine.

Virtual machine has sufficient memory/hard disk, etc.

Version-Release number of selected component (if applicable): 17


How reproducible: Always


Steps to Reproduce:
1. Start VM using the Live CD.
2. Select "Install to hard drive option"
3. Partition as needed.
4. Choose to install bootloader in /dev/sda (default option)
  
Actual results:

Installation will proceed normally till it reaches bootloader installtion stage. There, a warning dialog box appears with the following message.

"There was an error installing the bootloader. The system may not  be bootable".

The system does not boot and "No bootable medium found" error is thrown upon rebooting.

Expected results:

Installtion of bootloader and hence installation of OS should be succesful.

Additional info:
I have not tried installing directly to a computer. So, cannot comment on that front.
Comment 1 Mukundan Ragavan 2012-05-05 21:37:16 EDT
This was tried on a F17 x86_64 machine. The live image tried was 32-bit image.
Comment 2 Chris Lumens 2012-05-07 09:19:21 EDT
Please attach /tmp/syslog, /tmp/program.log, and /tmp/anaconda.log to this bug report.  Thanks.
Comment 3 Mukundan Ragavan 2012-05-07 09:54:29 EDT
Created attachment 582674 [details]
anaconda.log
Comment 4 Mukundan Ragavan 2012-05-07 09:55:01 EDT
Created attachment 582676 [details]
program.log
Comment 5 Mukundan Ragavan 2012-05-07 09:56:15 EDT
There was no /tmp/syslog.
Comment 6 Jesse Keating 2012-07-18 13:15:01 EDT
Not able to reproduce this with the F17 final.  The code is in a different order now too.

Note You need to log in before you can comment on or make changes to this bug.