Bug 819270 - virt-manager missing dependency on spice-gtk-python
virt-manager missing dependency on spice-gtk-python
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 757874 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 01:17 EDT by Ian Pilcher
Modified: 2012-06-15 20:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 20:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2012-05-06 01:17:22 EDT
Description of problem:
virt-manager should depend on spice-gtk-python

Version-Release number of selected component (if applicable):
virt-manager-0.9.1-3.fc17.noarch

How reproducible:
100%

Steps to Reproduce:
1.  Start virt-manager
2.  Open guest with SPICE display
3.  Start guest
  
Actual results:
Guest console is not visible.  Instead this message is displayed:

  Cannot display graphical console
            type 'spice':
  No module named SpiceClientGtk


Expected results:
Guest console should be visible/usable.

Additional info:
Installing spice-gtk-python fixes the problem.
Comment 1 Jeff Raber 2012-05-29 23:44:34 EDT
see also: bug 697729
Comment 2 Tom Horsley 2012-06-02 16:42:27 EDT
I just ran into the same problem. I can run virt-viewer separately to see the console. I guess I'll install spice-gtk-python. (Yep, that fixes the problem)
Comment 3 Cole Robinson 2012-06-06 17:24:30 EDT
*** Bug 757874 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-06-06 17:51:28 EDT
virt-manager-0.9.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.1-4.fc17
Comment 5 Fedora Update System 2012-06-07 18:52:47 EDT
Package virt-manager-0.9.1-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.1-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9000/virt-manager-0.9.1-4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-06-15 20:05:33 EDT
virt-manager-0.9.1-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.