Bug 819291 - ovirt-engine-backend [TEXT]: please change "VM image is locked" to "Disk X is locked" error on all disk actions
ovirt-engine-backend [TEXT]: please change "VM image is locked" to "Disk X is...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Tal Nisan
Gadi Ickowicz
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 06:20 EDT by Dafna Ron
Modified: 2016-02-10 11:36 EST (History)
11 users (show)

See Also:
Fixed In Version: SI13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (26.88 KB, application/x-xz)
2012-05-06 06:20 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-05-06 06:20:07 EDT
Created attachment 582427 [details]
log

Description of problem:

trying to create a template after I started a move disk operation gives an error:

    Cannot add Template: VM's image is locked. Please try again in a few minutes.

since vm is no longer locked for actions that involve only disk operation we should change this error to "Disk X is locked" and not "Vm's image is locked" 

Version-Release number of selected component (if applicable):

si3

How reproducible:

100%

Steps to Reproduce:
1. move a disk between two domains
2. try to create template
3.
  
Actual results:

only the disk is in locked state (sub tab under vm or disk tab) and vm is does not appear locked. 

Expected results:

Error message should be changed 

Additional info:log

2012-05-06 13:12:01,719 WARN  [org.ovirt.engine.core.bll.AddVmTemplateCommand] (ajp--0.0.0.0-8009-7) [4dd3872c] CanDoAction of action AddVmTemplate failed. Reasons:VAR__ACTION__
ADD,VAR__TYPE__VM_TEMPLATE,ACTION_TYPE_FAILED_VM_IMAGE_IS_LOCKED
Comment 1 Miki Kenneth 2012-06-04 07:58:00 EDT
If we don't have the name of the specific image name, we should changed the message to be more general. VM in lock state (probably, one it's disk images is currently locked by asynchronous storage operation).
Comment 2 Tal Nisan 2012-06-11 08:31:01 EDT
http://gerrit.ovirt.org/#/c/4945/
Comment 3 Gadi Ickowicz 2012-07-29 05:20:20 EDT
Checked by creating a VM, installing OS on it, moving the disk to a different domain and then attempting to create a template. 

Error message in the web GUI now reads: 
    Cannot add Template: The disks <disk_name> are locked. Please try again in a few minutes.

Note You need to log in before you can comment on or make changes to this bug.