Bug 819314 - [abrt] kernel: WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
[abrt] kernel: WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:8d6b64a29a38df0076326e8fb3d...
:
: 817417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 10:37 EDT by Sunil
Modified: 2012-05-07 15:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 15:26:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunil 2012-05-06 10:37:54 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.4-3.fc16.x86_64 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks=0 LANG=en_US.UTF-8
event_log:      2012-05-06-09:37:23> Smolt profile successfully saved
kernel:         3.3.4-3.fc16.x86_64
reason:         WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
time:           Sun 06 May 2012 09:36:38 AM CDT

backtrace:
:WARNING: at lib/list_debug.c:53 __list_del_entry+0xa1/0xd0()
:Hardware name: System Product Name
:list_del corruption. prev->next should be ffff8801d5555100, but was ffff8801d5555300
:Modules linked in: tcp_lp fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 ip6table_filter nf_defrag_ipv4 xt_state ip6_tables nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm microcode sp5100_tco r8169 btusb snd_timer snd i2c_piix4 bluetooth soundcore snd_page_alloc rfkill asus_atk0110 edac_core edac_mce_amd ppdev mii parport_pc parport fam15h_power k10temp usblp uinput sunrpc ata_generic pata_acpi pata_atiixp wmi usb_storage radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 2652, comm: chrome Not tainted 3.3.4-3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057abf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057bb6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8116c1c6>] ? kfree+0x126/0x150
: [<ffffffff812d4651>] __list_del_entry+0xa1/0xd0
: [<ffffffff81182bf6>] file_sb_list_del+0x26/0x50
: [<ffffffff81182da8>] fput+0x128/0x220
: [<ffffffff8125be35>] ? exit_sem+0x215/0x230
: [<ffffffff8117f526>] filp_close+0x66/0x90
: [<ffffffff8105b5c8>] put_files_struct+0x88/0xf0
: [<ffffffff8105b6db>] exit_files+0x4b/0x60
: [<ffffffff8105bbc8>] do_exit+0x1a8/0x8d0
: [<ffffffff8119ec36>] ? mntput+0x26/0x40
: [<ffffffff8105c642>] do_group_exit+0x42/0xa0
: [<ffffffff8105c6b7>] sys_exit_group+0x17/0x20
: [<ffffffff815fbee9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 88772edc-baf1-4760-8a3e-1d41e0c12b22
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 6599.31
:CPU Vendor: AuthenticAMD
:CPU Model: AMD FX(tm)-6100 Six-Core Processor
:CPU Stepping: 2
:CPU Family: 21
:CPU Model Num: 1
:Number of CPUs: 6
:CPU Speed: 3300
:System Memory: 7970
:System Swap: 10015
:Vendor: System manufacturer
:System: System Product Name System Version
:Form factor: Desktop
:Kernel: 3.3.4-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4098:17296:4163:33859) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode]
:(4130:38407:4163:33854) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 3)
:(4130:38409:4163:33854) pci, pcieport, PCI/PCI, RS780/RS880 PCI to PCI bridge (PCIE port 5)
:(4098:43672:4163:43672) pci, snd_hda_intel, MULTIMEDIA, NI Caicos HDMI Audio [AMD RADEON HD 6450]
:(4130:38401:4163:33854) pci, None, HOST/PCI, M5A88-V EVO
:(4130:5637:0:0) pci, None, HOST/PCI, Family 15h Processor Function 5
:(4130:5636:0:0) pci, fam15h_power, HOST/PCI, Family 15h Processor Function 4
:(4130:5633:0:0) pci, None, HOST/PCI, Family 15h Processor Function 1
:(4130:5632:0:0) pci, None, HOST/PCI, Family 15h Processor Function 0
:(4130:5635:0:0) pci, k10temp, HOST/PCI, Family 15h Processor Function 3
:(4130:5634:0:0) pci, None, HOST/PCI, Family 15h Processor Function 2
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4130:38403:4163:33854) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (ext gfx port 0)
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(4098:17308:4163:33859) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:0:0) pci, None, SERIAL, SBx00 SMBus Controller
:(4098:17309:4163:33859) pci, None, PCI/ISA, M5A88-V EVO
:(4098:17283:4163:33819) pci, snd_hda_intel, MULTIMEDIA, M5A88-V EVO
:(4098:17305:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:26489:4163:986) pci, radeon, VIDEO, NI Caicos [AMD RADEON HD 6450]
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(4098:17302:4163:33859) pci, ehci_hcd, USB, M5A88-V EVO
:(4098:17303:4163:33859) pci, ohci_hcd, USB, M5A88-V EVO
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/VolGroup-lv_root / ext4 4096 4096 13081819 9216779 8561419 3276800 2926755 2926755
:/dev/sda1 /boot ext4 1024 1024 508745 410060 384460 128016 127782 127782
:/dev/mapper/VolGroup-lv_home /home ext4 4096 4096 23229254 21543933 20380669 5816320 5807564 5807564
:
Comment 1 Josh Boyer 2012-05-07 11:20:00 EDT
You had a single bit flip in memory.  Can you run memtest86+ on this overnight and see if it produces any errors?
Comment 2 Dave Jones 2012-05-07 15:20:15 EDT
*** Bug 817417 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2012-05-07 15:26:20 EDT
Like the other bugs, I think this is a hardware problem that we can't do anything about.

Note You need to log in before you can comment on or make changes to this bug.