Bug 819315 - quirk needed for usb-audio speakers, 1130:1620 (Logitech S150 branded)
quirk needed for usb-audio speakers, 1130:1620 (Logitech S150 branded)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 10:57 EDT by Colin Macdonald
Modified: 2013-03-14 14:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-14 14:17:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Macdonald 2012-05-06 10:57:47 EDT
Most of volume change on these speakers happens in the first few "steps" using pulseaudio, which makes easy adjustment difficult.  I gather this is likely because of broken dB data:

http://www.freedesktop.org/wiki/Software/PulseAudio/Backends/ALSA/Decibel

Making the following change in /etc/pulse/default.pa works around the problem:

-load-module module-udev-detect
+load-module module-udev-detect ignore_dB=1

Here is the data about the device so a quirk can be added.  Let me know if anything else is required.

# lsusb:
Bus 001 Device 018: ID 1130:1620 Tenx Technology, Inc.

# aplay -l | grep "USB Audio"
card 1: AUDIO [USB  AUDIO], device 0: USB Audio [USB Audio]

----

Also, note it has the unimaginative name of "AUDIO" and "USB  AUDIO".  Can we quirk around that too?  "Logitech S-150"?

I gather from other bugs about this sort of thing that more descriptive names exist:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=662901

----

I used "dbverify" from the page above and it does indeed produce different tones.  In fact it doesn't appear to be even monotonic.

./dbverify AUDIO PCM 500 10000
./dbverify AUDIO PCM 500 17152

The 17152 (max value) is *quieter* than 10000.
Comment 1 Josh Boyer 2013-03-14 14:17:41 EDT
Our apologies for not getting to this sooner.

We suggest you work with the upstream ALSA developers to get this fixed there if it hasn't been already.  You can email the relevant details to the alsa-devel list and hopefully they should be able to work with you on it.

Note You need to log in before you can comment on or make changes to this bug.