Bug 819325 - dhcp upgrade provides no clue about new dhcpd.conf location being used
dhcp upgrade provides no clue about new dhcpd.conf location being used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 11:58 EDT by Paul Wouters
Modified: 2012-06-17 18:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 18:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2012-05-06 11:58:51 EDT
Description of problem:
I used /etc/dhcpd.conf and it was not clear that the location the binary uses is now /etc/dhcp/dhcpd.conf.
Even running dhcpd -f /etc/dhcpd.conf failed for me. I had to move to file into /etc/dhcpd/

It would be nice if the initscript deals with this, via a warning or some kind of log message, as the dhcpd error is just the screen full of disclaimer without an actual error.

Version-Release number of selected component (if applicable):
dhcp-4.2.3-8.P2.fc16
Comment 1 Jiri Popelka 2012-05-07 06:01:10 EDT
(In reply to comment #0)
> I used /etc/dhcpd.conf and it was not clear that the location the binary uses
> is now /etc/dhcp/dhcpd.conf.

This change is more that 3 years old, we've used /etc/dhcp/dhcpd.conf since Fedora-11/RHEL-6.

> It would be nice if the initscript deals with this, via a warning or some kind
> of log message, as the dhcpd error is just the screen full of disclaimer
> without an actual error.

There's a scriptlet in spec file which handles the F10->F11, RHEL5->RHEL-6 upgrade case and copies /etc/dhcpd.conf into /etc/dhcp/dhcpd.conf during upgrade/installation.
But I don't think some warning would be possible because the dhcp package installs empty /etc/dhcp/dhcpd.conf which it then reads and has no idea that you actually wanted to use /etc/dhcpd.conf
I could explicitly add '-cf /etc/dhcp/dhcpd.conf' into the service file when starting dhcpd, so 'service dhcpd status' or 'systemctl status dhcpd.service' will show that dhcpd actually reads this file.
Comment 2 Paul Wouters 2012-05-09 11:12:20 EDT
Perhaps I broke a softlink and did not realise it?

Some kind of warning like you described would be nice. It took me two hours before I realised the problem, as the dhcpd error message was totally useless 

In fact, it just spew the blob of text in /var/log/messages without an actual error, but refused to run.
Comment 3 Fedora Update System 2012-06-05 06:55:27 EDT
dhcp-4.2.4-0.8.rc2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dhcp-4.2.4-0.8.rc2.fc17
Comment 4 Fedora Update System 2012-06-07 18:52:34 EDT
Package dhcp-4.2.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dhcp-4.2.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8999/dhcp-4.2.4-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-06-17 18:23:25 EDT
dhcp-4.2.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.