Bug 819335 - Symmetrica has too common global names and problems with headers inclusion order
Symmetrica has too common global names and problems with headers inclusion order
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: symmetrica (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-06 13:28 EDT by Paulo Andrade
Modified: 2012-05-26 13:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 13:19:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulo Andrade 2012-05-06 13:28:31 EDT
I am just starting to contribute to fedora, so, do not know all the
procedures to get patches in other packages, but please consider and
review the packages at:

Spec URL: http://kenobi.mandriva.com/~pcpa/symmetrica.spec
SRPM URL: http://kenobi.mandriva.com/~pcpa/symmetrica-2.0-7.fc16.src.rpm

  It adds a patch to rename the global "sum" and "sort" symbols, as
well as allow including macro.h before def.h (otherwise there is
kind of a cyclic loop there), and also a patch to not print a banner
the first time a function from symmetrica is called (what can be
annoying or cause several sagemath doctests to fail due to the
banner in output).
Comment 1 Conrad Meyer 2012-05-08 00:59:45 EDT
Go here: https://admin.fedoraproject.org/pkgdb/acls/name/symmetrica and apply for watchbugzilla / watchcommits / commit / approveacls — the first two will be approved automatically, and I'll approve the second two. Then you can just apply the changes yourself =).
Comment 2 Paulo Andrade 2012-05-08 21:03:03 EDT
Thanks. I selected aproveacls, but I do not think I need it.
Also, Jerry already corrected the package, so, I think I will
not look at it again for some time, but something that should
be useful is to rename more symbols, because it is very easy
to get hard to debug errors if those symbols end up being
used by another library.
Comment 3 Paulo Andrade 2012-05-10 11:14:30 EDT
  I commented only in scitech@lists.fedoraproject.org, and that I would
prefer to not change it right now because Jerry did work on an update
and other patches, but there is still a problem in symmetrica.

  First there was the problem reported here, and now there is a pending
update for symmetrica, but there is another one I found after managing
to actually build and run sagemath in the buildroot environment, to
generate its documentation on fedora 16, commented at:

http://lists.fedoraproject.org/pipermail/scitech/2012-May/000119.html

  The solution should be to not define -DLOCALTRUE otherwise, programs
linking to symmetrica should define the stub functions local_anfang()
and local_ende()
Comment 4 Paulo Andrade 2012-05-18 19:50:13 EDT
  I will use this case to get more confidence with fedpkg
and correct the problem with compiling it with -DLOCALTRUE,
what generates calls to undefined functions.

  Blame me if I make anything wrong :-)
Comment 5 Paulo Andrade 2012-05-26 13:19:28 EDT
Corrected in rawhide, and package should be only used by the
sagemath package when all dependencies are resolved, otherwise,
for custom usages it is easy to workaround the problem.

Note You need to log in before you can comment on or make changes to this bug.