Bug 819336 - Anaconda doesn't allow me to create LVM partition
Anaconda doesn't allow me to create LVM partition
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-05-06 13:39 EDT by Szymon Gruszczynski
Modified: 2012-05-07 11:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-05-07 11:31:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot (98.35 KB, image/png)
2012-05-06 13:39 EDT, Szymon Gruszczynski
no flags Details

  None (edit)
Description Szymon Gruszczynski 2012-05-06 13:39:35 EDT
Created attachment 582477 [details]

Description of problem:
In F17 Beta, when I try to create LVM partition on disk, Anaconda gives me an error:

Partitions of type 'physical volume (LVM)' must be constrained to a single drive.  To do this, select the drive in the 'Allowable Drives' checklist.

Of course proper drive is selected. Error like that occures whenever I choose SSD or HDD, or whenever I choose size (fixed, maximum, fill all space up to).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot
2. click
3. enjoy
Actual results:
Error mentioned above

Expected results:
creating physical volume

Additional info:
Comment 1 Szymon Gruszczynski 2012-05-06 13:47:43 EDT
lspci -v
Comment 2 David Lehman 2012-05-07 10:40:51 EDT
The screenshot does not include sdd in the "Allowable Drives" list, so it remains unclear whether or not you had two drives selected.

I just tried and was unable to trigger the error you report without having multiple allowable drives selected. Is it possible for you to make a screencast/video of the process?
Comment 3 Szymon Gruszczynski 2012-05-07 11:31:38 EDT
you probably wont believe me (I wouldn't)- but its fine now. I was doing an video (with my phone- i do install it on a "real" hardware, not inside VM), it worked fine o.O
seriously- i've followed the same steps as yesterday (I could swear to God(s)) and its fine now :)
Well- anyway- sorry for problems.

PS. hm... the screenshot includes sdd in "allowable drivers" :) this is the only one drive checked (everything else is unchecked) :)

have a nice day,

Note You need to log in before you can comment on or make changes to this bug.