Bug 819411 - quota: some temporary mounts are not unmount after operations finish
quota: some temporary mounts are not unmount after operations finish
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
pre-release
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-05-07 03:06 EDT by Saurabh
Modified: 2016-01-19 01:10 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:11:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-05-07 03:06:28 EDT
Description of problem:
quota creates some temporary mounts while doing some operations like quota list and setting limit.

so these temporary mounts are suppose to be unmounted after operation finishes. but presently some are not.

Version-Release number of selected component (if applicable):
3.3.0qa39

How reproducible:
sometimes(intermittent)

Steps to Reproduce:
1. create a dist-rep volume 
2. put up the quota limit
3. try quota list command
  
Actual results:
 the temporary mount created is not umounted

Expected results:
 all mounts should get umounted

Additional info:
Comment 1 Saurabh 2012-05-07 03:07:27 EDT
the mount command displays the existing mounts,


[root@RHS2 ~]# mount
/dev/sda3 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_u:object_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/vda1 on /export type xfs (rw)
localhost:quota_dist_rep on /tmp/mntBhnqlj type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
localhost:quota_dist_rep on /tmp/mntlUkyK6 type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
localhost:quota_dist_rep on /tmp/mntqAF01z type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
[root@RHS2 ~]#
Comment 2 Saurabh 2012-05-07 03:09:39 EDT
sosreport copied to the intended location
Comment 3 Saurabh 2012-05-10 08:39:11 EDT
moving this to verified, as issue was seen on 39 due to some bad patch,  but in qa40 it's already working.

Note You need to log in before you can comment on or make changes to this bug.