Bug 819421 - [abrt] kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie.c:1106 iwl_trans_pcie_tx+0x75b/0x7c0 [iwlwifi]() (Not tainted)
[abrt] kernel: WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie.c:1106...
Status: CLOSED DUPLICATE of bug 818672
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stanislaw Gruszka
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-07 03:46 EDT by David Jaša
Modified: 2013-04-11 05:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-04 03:20:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: sosreport.tar.xz (1.93 MB, text/plain)
2012-05-07 03:48 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-05-07 03:46:17 EDT
libreport version: 2.0.9
abrt_version:   2.0.8
cmdline:        ro root=/dev/mapper/root_vg-rhel6 rd_LVM_LV=root_vg/rhel6 rd_LVM_LV=root_vg/swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=cs_CZ.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=129M@0M rhgb quiet
comment:        no obvious trigger. Might be related to bug 818672.
kernel:         2.6.32-269.el6.x86_64
reason:         WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie.c:1106 iwl_trans_pcie_tx+0x75b/0x7c0 [iwlwifi]() (Not tainted)
time:           Ne 6. květen 2012, 22:28:51 CEST

sosreport.tar.xz: Binary file, 2024740 bytes

backtrace:
:WARNING: at drivers/net/wireless/iwlwifi/iwl-trans-pcie.c:1106 iwl_trans_pcie_tx+0x75b/0x7c0 [iwlwifi]() (Not tainted)
:Hardware name: 4384AT6
:Modules linked in: iwlwifi mac80211 cfg80211 hidp fuse ebtable_nat ebtables kspiceusb(U) rfcomm sco bnep l2cap autofs4 sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf bridge stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables ipv6 ipt_REJECT xt_state iptable_filter ipt_MASQUERADE iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 ip_tables fpu aesni_intel cryptd aes_x86_64 aes_generic xts gf128mul dm_crypt vhost_net macvtap macvlan tun kvm_intel kvm uinput thinkpad_acpi arc4 sg uvcvideo videodev v4l2_compat_ioctl32 btusb bluetooth rfkill microcode intel_ips i2c_i801 iTCO_wdt iTCO_vendor_support shpchp snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc e1000e ext4 mbcache jbd2 sr_mod cdrom sd_mod crc_t10dif firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core ahci wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video output dm
:_mirror dm_region_hash dm_log dm_mod [last unloaded: cfg80211]
:Pid: 0, comm: swapper Not tainted 2.6.32-269.el6.x86_64 #1
:Call Trace:
:<IRQ>  [<ffffffff8106b6b7>] ? warn_slowpath_common+0x87/0xc0
:[<ffffffff8106b70a>] ? warn_slowpath_null+0x1a/0x20
:[<ffffffffa07b5cdb>] ? iwl_trans_pcie_tx+0x75b/0x7c0 [iwlwifi]
:[<ffffffffa07a32f0>] ? iwlagn_tx_skb+0x4d0/0x810 [iwlwifi]
:[<ffffffffa0799ffa>] ? iwlagn_mac_tx+0x1a/0x30 [iwlwifi]
:[<ffffffffa077e072>] ? __ieee80211_tx+0x72/0x250 [mac80211]
:[<ffffffffa077f7dc>] ? ieee80211_tx_pending+0x15c/0x260 [mac80211]
:[<ffffffff81074245>] ? tasklet_action+0xe5/0x120
:[<ffffffff81073e31>] ? __do_softirq+0xc1/0x1e0
:[<ffffffff810db750>] ? handle_IRQ_event+0x60/0x170
:[<ffffffff8100c24c>] ? call_softirq+0x1c/0x30
:[<ffffffff8100de85>] ? do_softirq+0x65/0xa0
:[<ffffffff81073c15>] ? irq_exit+0x85/0x90
:[<ffffffff815054b5>] ? do_IRQ+0x75/0xf0
:[<ffffffff8100ba53>] ? ret_from_intr+0x0/0x11
:<EOI>  [<ffffffff812cd52e>] ? intel_idle+0xde/0x170
:[<ffffffff812cd511>] ? intel_idle+0xc1/0x170
:[<ffffffff810990bd>] ? sched_clock_cpu+0xcd/0x110
:[<ffffffff814072a7>] ? cpuidle_idle_call+0xa7/0x140
:[<ffffffff81009e06>] ? cpu_idle+0xb6/0x110
:[<ffffffff814e3d5a>] ? rest_init+0x7a/0x80
:[<ffffffff81c21f7b>] ? start_kernel+0x424/0x430
:[<ffffffff81c2133a>] ? x86_64_start_reservations+0x125/0x129
:[<ffffffff81c21438>] ? x86_64_start_kernel+0xfa/0x109
Comment 1 David Jaša 2012-05-07 03:48:04 EDT
Created attachment 582561 [details]
File: sosreport.tar.xz
Comment 2 David Jaša 2012-05-07 03:53:26 EDT
HW: Thinkpad T510, lspci:

# lspci -vvvn -s 03:00.0
03:00.0 0280: 8086:4238 (rev 35)
	Subsystem: 8086:1111
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 32
	Region 0: Memory at f2400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: [c8] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
		Address: 00000000fee0f00c  Data: 417e
	Capabilities: [e0] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
			MaxPayload 128 bytes, MaxReadReq 128 bytes
		DevSta:	CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <128ns, L1 <32us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
	Capabilities: [100] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UESvrt:	DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
		AERCap:	First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
	Capabilities: [140] Device Serial Number 00-24-d7-ff-ff-3e-b7-30
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
Comment 4 RHEL Product and Program Management 2012-05-11 00:04:14 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 David Jaša 2012-05-11 04:57:26 EDT
Proposing as 6.3 RC blocker.
Comment 6 John W. Linville 2012-05-14 14:05:26 EDT
Is there an actual interruption of service?  Or just the warning output in dmesg?
Comment 7 David Jaša 2012-05-16 03:03:33 EDT
In this case, not. But it might be the cause of bug 818672 (happened to me at the same network).
Comment 8 John W. Linville 2012-05-16 09:36:01 EDT
If there is a cause->effect relationship with that bug, I think it probably goes the other way.

FWIW, I think that using 11n_disable=1 will prevent this from happening (albeit with the loss of 802.11n functionality).
Comment 11 Stanislaw Gruszka 2012-06-04 03:20:44 EDT
This warning is consequence of firmware hug bug 818672, or vice versa, indicate bad condition which make firmware hung. Anyway there is no reason for having separate bug reports.

*** This bug has been marked as a duplicate of bug 818672 ***
Comment 12 Stanislaw Gruszka 2013-04-11 05:35:47 EDT
Remove ABRT hash to avoid spurious duplicates of this bug.

Note You need to log in before you can comment on or make changes to this bug.